Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Extremely annoying VGA-driver (http://www.hardwarecanucks.com/forum/troubleshooting/55959-extremely-annoying-vga-driver.html)

superjona August 7, 2012 06:56 AM

Extremely annoying VGA-driver
 
Hey everyone,

I recently bought some components and I'm having troubles with the VGA-driver.

Installed a HD 7770 Ghz Edition from Club 3D via HDMI, together with a i5 3450 and ASROCK H77M mainboard.

When there's no VGA-drivers installed, the PC functions normally (gaming doesn't work, but that's pretty logical)

When I tried to install the VGA-drivers, I ran in some troubles. Used beta drivers, recent drivers, even the CD-drivers, and they all don't work. The display is not fully filled (borders), and all sound is gone. It's connected to some monitorspeakers.

So I deleted the drivers, but it's not optimal because I can't get gaming to work without drivers.

Here's a Speccy link.

Would a BIOS update help? Any ideas?

Thanks in advance!

SKYMTL August 7, 2012 08:28 AM

Can you provide some additional info?

Are you downloading drivers from the Game.AMD.com site?

What kind of monitor are you using? Is it a HDTV monitor or just a standard PC monitor?

Is the HDMI connector plugged into and adaptors?

Is the HDMI cable running from the primary HDMI port on your graphics card to the monitor?

Did you disable the onboard VGA in the motherboard's BIOS?

Are you running Lucid's drivers as well?

How did you delete the drivers?


Let us know and we'll be able to get to the next bit of troubleshooting. :)

superjona August 7, 2012 09:47 AM

Thanks for your response.

I didn't download the drivers via game.amd.com, I just went to AMD.com and looked for my drivers there. Also tried to use the drivers from the included disk.

I'm using a standard Philips 22 inch 1080p monitor, plugged in via HDMI with no adapters whatsoever. I did connect the monitor via a standard 3.5 inch audiojack for sound to the computer.

There is only one HDMI port on the graphics card, and no i'm not using the one from the mainboard.

Not running any Lucid Virtu drivers, I just deleted the drivers by executing the driver installation file, and I chose for 'uninstall'.

I haven't tried disabling the onboard graphics in the BIOS yet. It's so frustrating that everything (except gaming) works perfectly without drivers.

I'll have access to the computer thursday, I'll try updating the BIOS, disabling the IGP and download some new drivers on game.amd.com.

Thanks for your help! It's greatly appreciated. :thumb:

Chareon August 7, 2012 10:13 AM

When you've got the drivers installed, have you made sure to set the resolution to 1920x1080? It might just not be stretching the output to fit the panel. (Alternatively you could check the scaling settings, I can't recall where these are under the CCP at the moment though.)

As for the sound, it sounds like it is trying to route the sound out the HDMI when the drivers are installed, try selecting the sound output device.

SKYMTL August 7, 2012 11:28 AM

Post the results here. However, I think you will need to ensure your resolution is set to 1920 x 1080 and your monitor's scaling setting (typically in the monitor's menu) is a the necessary point. IE: 1:1.

superjona August 7, 2012 11:37 AM

Already checked the resolution, was at full 1080p.

The Philips monitor has a terrible menu, so I doubt i'll be able to change something there.

I'll post some results thursday, hope it works!

superjona August 11, 2012 06:47 AM

It worked!

Downloaded the latest drivers from game.amd.com, these were the only was with no install-errors.

Fixed the sound with a set of speakers, and fixed the display in the CCC manager. With the previous drivers, this was impossible.

SKYMTL and Chareon, thanks for your help!

This topic can be closed.

SKYMTL August 11, 2012 07:50 AM

We'll keep the topic open since it may help others.

Congrats on your fix!


All times are GMT -7. The time now is 07:48 AM.