Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   (Solved) Disk Wiping stole my Gbs (http://www.hardwarecanucks.com/forum/troubleshooting/55533-solved-disk-wiping-stole-my-gbs.html)

le2key July 16, 2012 05:18 PM

(Solved) Disk Wiping stole my Gbs
 
Hey guys just wanted to let you know I fixed the problem, fzabkar at the WD forums suggested that an HPA had been created in my harddrive and I had to restore it with one of the programs he posted. I'll leave the original post below + solution for anyone who comes across the same issue I did. And thanks for the help on this end as well. PEACE OUT.

---------------------------------------------------
fzabkar wrote:
It may be that a HPA has been created. If so, then the solution is to use a utility such as HDAT2 or HDD Capacity Restore Tool to restore the drive's full factory capacity.

For example, to "change the native size" of your HDD, see page 5 of the HDAT2 "cook book".

Explanation of Host Protected Area:
Host protected area - Wikipedia, the free encyclopedia

HDD Capacity Restore Tool:
HDDGURU: HDD Capacity Restore Tool

HDAT2/CBL Hard Disk Repair Utility:
HDAT2/CBL Hard Disk Repair Utility
HDAT2 FAQ
http://www.hdat2.com/files/cookbook_v11.pdf
---------------------------------------------------

le2key wrote:
Summer Project: Implementation of a home server, and as such I decided to wipe my harddrives (2x Western Digital 640gb Caviar Black).

Sorry for making another thread, I wanted to use my previous SSD thread but I couldn't change the title, guess it only works for the classifieds. Anyway..

The first program I used was SecureErase from CMRR everything was going well until I followed up with a second wipe with DBAN (autonuke: DoD, 3 passes), and for some reason DBAN listed one of my drives as 127gb. I initially thought it was ditzing out and was a simple display error but when the wipe was done, I formatted the drives and still... one of them was still displaying only 127gb out of the original 597gb.

I've tried to use Window's Disk Management and PartedMagic to find the unallocated space but there is non-detected; like as if 470 gigs just packed up and left. The other WD 640gb is fine.


Again, had some great help in my last thread so any more from you guys is GREATLY appreciated.


System used for wipe
C2D E6600
OCZ 4Gb Ram 1066mhz
Gigabyte GA-X48-DS4
Vista 32bit

Main System
Core i5 760
Corsair 8gb ram 1600mhz
Gigabyte P55A-UD4P
Win7 64bit

Problem drive MDL #: WD6401AALS-00JB71

JD July 16, 2012 05:46 PM

Try running this: WD Support / Downloads / SATA & SAS / WD Black

Maybe it'll be able to fix it, not sure. Have you tried changing SATA ports or plugging it into another PC? 127GB was the old-school limit of hard drive sizes due to BIOS limitations at the time.

enaberif July 16, 2012 05:48 PM

Its a very old and uncommon but still common type bug.

Run the WD Diagnostics tool and it should fix it.

KaptCrunch July 17, 2012 07:03 AM

P55A-UD4P motherboard revision: 2 current bios is F14

also check wdc for firmware updates for your drive

le2key July 17, 2012 02:15 PM

Yeah my bios is the current F14 and there are no firmware updates for my drive.

I was hopeful that the diagnostics tool would work but unfortunately it didn't. The WD forums suggested I write zeros to the drive as well, but it seems like this is irreversible.

Before I write this off and purchase a new drive, is there anything else I can attempt?

Also, sorry but I forgot to mention that the drives were in RAID 0 (128kb stripe) before the disk wipe.


All times are GMT -7. The time now is 01:14 AM.