Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   URGENT! Pulling data off old IDE hard drives (http://www.hardwarecanucks.com/forum/troubleshooting/55022-urgent-pulling-data-off-old-ide-hard-drives.html)

bigFOIG June 24, 2012 05:12 PM

URGENT! Pulling data off old IDE hard drives
 
I've been trying to grab some data off some IDE drives that I have but I'm having some trouble. What I did was go into my IDE drive, Select all, Copy, and pasted into a folder in my external hard drive. Only 1 GB out of my 30 GB worth of stuff is copied. Only 3 root folders of the drive copy, out of the 10 folders that are in the drive. And even then, the 3 folders that did copy, the content inside is barely copied.

When I'm trying to even look at my data, it gives me a message. Something along the lines of "You don't have permission to access these files". I've tried going to the properties of my drive and giving myself full control of the drive. Doesn't work. It seems like this method works when I do individual folders though. I don't want to spend an hour giving myself Full Control for every single folder.

I'm thinking maybe these problems are linked?

clone63 June 24, 2012 05:23 PM

Kinda sounds like it. You might want to look into copying the entire partition with Acronis or something similar.

If the permissions seem to be the main obstacle, try an OS that ignores that, like a quick UBCD4Windows: UBCD for Windows

frontier204 June 24, 2012 07:03 PM

Yep it sounds like the folders were marked "private" by Windows (e.g. a "My Documents" folder).
I second clone63's idea of using an OS that doesn't care about permissions. I personally used Linux live CDs to do this, e.g. Ubuntu or Fedora Live, since Linux's NTFS doesn't retain permissions on a copy-paste by default.

Another thing you could try is running a zip program like 7-zip or FilZip as administrator and trying to zip the contents out of the IDE drive into a disk that you do have control over. Then you can unzip as NOT administrator. Note I haven't tried this with Windows.

bigFOIG June 24, 2012 07:55 PM

I thought about using UBCD or BartPE. I didn't want to go the UBCD route, since I don't have an optical drive installed, nor do I have the disk handy. I guess I'll be doing that then. Thanks guys.


All times are GMT -7. The time now is 09:30 PM.