Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Mobo/PSU of death? (http://www.hardwarecanucks.com/forum/troubleshooting/54982-mobo-psu-death.html)

Kabramo June 22, 2012 04:09 PM

Mobo/PSU of death?
 
Bit of a background story to start off with; I bought the k60 from corsair, it worked fine for a few months and a few keys suddenly died. I RMAed it and recently got a replacement a few weeks ago, plugged it in and everything was gravy for a few weeks. Today the whole thing just up and died. Windows began scrolling through everything that was open (Firefox, steam etc) and not stopping. I tried alt tab, ctrl alt delete etc to no avail. I rebooted into safe mode and scanned to see if I had some sort of funky virus, no virus. I restarted again, booted into windows and tried the keyboard in notepad and no keys would work. The volume control and USB in the back of the keyboard still work however. Tried it on another computer (as well as different USB ports) to no avail.


So as of now I already have 2 dead USB ports (they go unused, obviously). I have an odd feeling that the keyboards themselves were fine, and were just killed by a bad USB port. Now my main issue is which is causing the problem: my PSU or Mobo? And how would I proceed to see which is the problem?

My PSU is a silverstone strider, 750W (SilverStone Technology Co., Ltd.- ST75F-P)

Motherboard is a gigabyte p55-usb3 (GIGABYTE - Motherboard - Socket 1156 - GA-P55-USB3 (rev. 1.0))


As far as the power supply goes, I've never had any issues with it (until potentially now).

As for my motherboard on the other hand, it already has two dead USB ports, and I had an issue with some RAM (I assume it was just bad RAM).

Any insight is greatly appreciated, I've never had this happen before and am at a loss of where to proceed.

Shadowmeph June 22, 2012 04:39 PM

Just a wild Guess here I would say Motherboard is going but that is a Guess

Kabramo June 22, 2012 04:48 PM

Quote:

Originally Posted by Shadowmeph (Post 636871)
Just a wild Guess here I would say Motherboard is going but that is a Guess

Yeah, I'm also leaning to that as well. In an odd way I hope it is the motherboard, I love my PSU. It would also give me a reason to upgrade to an i5 2500k and a SLI/XF capable mobo.

Krisso June 23, 2012 02:06 AM

I agree that it's likely the motherboard. If the PSU was indeed bad, the likelihood of it just damaging the USB ports is unlikely.


All times are GMT -7. The time now is 12:25 PM.