Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old June 10, 2012, 01:34 PM
Top Prospect
 
Join Date: May 2010
Posts: 111

My System Specs

Angry USB not working

My computer no longer reads usb drives. It doesn't put up an error, but they show up in Disk Management. I can't mount them or do anything with them because I get this:


The computer has been restarted, powered off for days, not sure what to do - any suggestions?
I thought that a pci-e USB 3 card might be causing a conflict, so I removed it. Still can't mount a drive.
Reply With Quote
  #2 (permalink)  
Old June 10, 2012, 01:52 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,781

My System Specs

Default

Maybe try re-installing the usb PCIe card so that you can see it in device manager and then uninstall any drivers + uninstall the hardware from device manager and then remove the card after shutting down?
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / Seagate Barracuda 1TB
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 250G Samsung 840 Series SSD / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #3 (permalink)  
Old June 10, 2012, 02:01 PM
Top Prospect
 
Join Date: May 2010
Posts: 111

My System Specs

Default

thanks - it's something to try. will report back tomorrow.

I get the above error msg when I try to asign a new letter to a drive I've plugged in (which doesn't show up in explorer)
Reply With Quote
  #4 (permalink)  
Old July 26, 2012, 06:43 PM
Top Prospect
 
Join Date: May 2010
Posts: 111

My System Specs

Default

sorry i never got back to you. i had some pretty major overlapping hardware issues:
- sata drives not detected
- ssd boot drive failure (RMA'd to AData)
- installed win8 for a while. usb worked under win8, but i don't work with win8.

too many variables now. i'm going to start a new thread about my laptop sound issues if you're a glutton for punishment however.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does anyone have a working OCZ SSD? Beastylemon Storage 51 September 14, 2011 10:54 AM
SMP not working Rison HardwareCanucks F@H Team 6 January 24, 2011 09:35 AM
Sfc not working odis172 Troubleshooting 8 June 20, 2009 12:57 AM
Help! CPU fan not working! Waldie Troubleshooting 29 May 4, 2009 10:55 AM
New and Not sure this is working. l-lunter HardwareCanucks F@H Team 14 April 21, 2009 04:41 PM