Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   2months of hell with downloads, please answer some questions for me. (http://www.hardwarecanucks.com/forum/troubleshooting/53915-2months-hell-downloads-please-answer-some-questions-me.html)

Impressive May 3, 2012 04:46 AM

2months of hell with downloads, please answer some questions for me.
 
Hi guys, "thank you" ahead of time for any replies.
First...the Problem.

I have a p6x58d premium motherboard.
I've had it for 2 years or so, and for the last 2 months I've not been able to post more than 130kb/s downloads in real world usage.
Watching a video on Youtube or trying to download a game from Steam is a painful crawl, and playing online games is sketchy at best (so, I just don't play anymore).
Speakeasy.net's speedtest shows my downloads to be 50mb/s, which is what my max is from my ISP, but on the other hand, Speedtest.net and Speedtest.shaw.ca, both show my downloads to be around 2mb/s. (Shaw being the ISP)
I get the same, max upload speeds, in every test and in each possible setup.
So, my first question is, "Why?"

I've narrowed down a lot of possibilities, here's a quick list:
-Hardware conflicts. I've tested everything...period. All works perfectly.
-Router issues. I have an Mx17 laptop, it runs perfectly over the network. (MTU is set properly)
-ISP connection. When connected directly to the modem, the issue still persists. Even after all of their troubleshooting. Glasnost reported clean posts as well.
-Viruses/Malware. It is a newly formatted hard-drive, but before that, I ran 5 different (and popular) programs in safemode(including combo cleaner), all showing up clean.
-Drivers/Bios. All updated, flashed, and good to go.
-I sent it away to a local network/computer repair guy, and $60 later, he couldn't find the issue.(thanks for trying)

Ok, so after all of that, I tried one last thing. I went out and bought a new Wireless NIC, and connected to the network at home. The speeds were exactly the same. Wireless NIC = Wired on-board NIC = Crap.

Anyhow, with knowing all of these things, there are a few obvious questions I need answered:
-Can your on-board network controller cause a separate network card to post similar download speeds, even after one or the other is disabled?
-Can an ISP limit one computer's speed over another, behind a router? (my guess is no...but maybe?)
-I know a virus can even survive a format, but usually they are really invasive. What's the chance that this is the cause? (again my guess is no)
-Can the internal IP have something to do with it?
-What am I not thinking of?

And honestly, without this being ridiculous, if someone can give me a clear-cut solution that doesn't involve "Go buy a new motherboard", I would be more than grateful. And if it does involve getting a new motherboard, well, I would want to know that too. Thanks again.

Nodscene May 3, 2012 05:49 AM

Your best bet at this point would be to try another computer if you can. Borrow a friends laptop or something and see if the problem persists. Then you can rule out your computer as the issue. I'd also try a new patch cables as well.

sswilson May 3, 2012 06:45 AM

If one PC works behind a router and the other doesn't, then it's something to do with the PC. Since you tried both wired and wireless nics I'm leaning towards something software related even though you did a fresh install...
  • Is it a legit copy of the OS (if it's pirated, might be a trojan built into the OS)?
  • Did you try testing your speeds immediately after the fresh install, and prior to installing any of your apps? (Again... could be a trojan in one of those apps, and/or something that's not playing nice with your router).
  • Related to above... after the clean install, leave all settings to auto rather than attempting any manual settings.
  • On the hardware side, remove the drivers for your nic (from device manager), and then delete the card itself before attempting to install your wireless nic (ignore initial requests to install drivers for the wired nic)
  • A bit extreme, but you might want to pack up your tower and try it at a friend's house to see if the issue moves with the tower, and that will tell you for sure if it's PC related.
Seriously.... my bet's on something software related on the tower.

frontier204 May 3, 2012 06:55 AM

To add to sswilson's advice, I'd also recommend a CMOS reset (battery pull or set the jumper, not just the option in BIOS) in case some DMA thing is messing up.

Impressive May 3, 2012 08:14 AM

Hi again...
 
SSwilson, it is a valid copy of Win7, and I should have mentioned that I did pack it all up and take it over to my parents place and tried it behind their firewall, the problem definitely resides with the computer. I will try what you suggested and delete any registry and drivers of the on-board nic and wireless card as well, and do a fresh install of the wireless. I think I did do that already when I formatted, but what the hay!

Frontier204, I updated the bios as well but I think I put back all of the overclocking settings to where they were before I even loaded windows, so I could try pulling out the battery as well.

Thx for the suggestions, I'll keep you posted.

sswilson May 3, 2012 08:30 AM

Have you tried installing a bandwidth monitor on the affect PC? Or even better... how about a bandwidth monitor on the laptop, and then share the laptop's wireless connection with the Nic to allow you to connect your PC to the internet through the laptop.... that will tell you if there's any hidden traffic on your PC.

KaptCrunch May 3, 2012 12:15 PM

lan driver for the correct OS

Impressive May 4, 2012 07:18 PM

Boo-urns.
 
Okay, well, thanks for the replies and suggestions peeps. I tried everything, I'm just gonna purchase a new board. Too bad P6 boards are extinct, cause the i7930 is still an excellent CPU, but out with the old and in with the new I guess.

For the record, I did reset the CMOS and started from scratch by way of popping out the motherboard battery. I disabled the on-board LAN via the BIOS and deleted any signs of it from the operating system. A fresh install and even switching PCI-E slots didn't make the wireless adapter work any smoother.

It's really a shame, because I love my machine the way it is except for this one glaring issue.
Anyhow, ciao for now!

Dwayne May 5, 2012 01:57 PM

I seem to have run into much the same problem. Never had it before and now I have noticed a sever slow down. All the other machines in the house are not having a problem, so it is not the router/modem combo. I changed ethernet cables, tried different ports on the router, tried to blow up the drivers and reinstall... all to no apparent avail.

My netbook gets 45 Mbps connected with a Cat5e, my main box, 3.5 Mbps.

Scanned for virus, did it all, I think. Not sure what changed but something did.

Windows 7 Home 64 bit is what I am using.

Impressive May 6, 2012 04:18 AM

UPDATE
 
Ok, Well I've narrowed it down to strictly my copy of 'Windows 7 64bit Home'. Reinstalling the same copy of windows on a new hard drive didn't change anything, but installing Ubuntu or Vista worked fine. Actually, better than fine, especially with the Linux install.
So, now the question is, "what do I do about Windows7"?
I've tried lots of things, and none of them have worked so far. I will keep searching and let you guys know.
Hopefully it will help you out too Dwayne.

Ciao for now...


All times are GMT -7. The time now is 06:55 AM.