Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 9, 2012, 04:44 PM
Rookie
 
Join Date: Dec 2011
Location: CANADA !!!! (Ontario)
Posts: 22

My System Specs

Default H100 pump noise

I recently purchased a corsair H100 cpu cooler and it has been doing really well keeping temps lol. However, i noticed that the pump of the unit was making this irritating wheezing sound and figured it could possibly due to air bubbles inside. When i tilt my case at an angle, the noise stops but continues once again once i place it back into the upright position. Any suggestions ? I also tried flicking the tubes but that didn't help much
Reply With Quote
  #2 (permalink)  
Old January 9, 2012, 05:02 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,602
Default

do you have it mounted properly?
Reply With Quote
  #3 (permalink)  
Old January 9, 2012, 05:08 PM
Rookie
 
Join Date: Dec 2011
Location: CANADA !!!! (Ontario)
Posts: 22

My System Specs

Default

Pretty sure i do... Rad attached to the top of my 650d case. Fans attached to the rad. Backplate on motherboard with appropriate pegs. Mounted the pump unit and secured with the thumb screw thingies. I checked the fittings and everything seems secure. No leaks no nothing. Temps are fine idling on my i7 2600k at around 30 degrees just the noise =/
Reply With Quote
  #4 (permalink)  
Old January 9, 2012, 05:32 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,944
Default

RMA it for if opened bye bye warranty
Reply With Quote
  #5 (permalink)  
Old January 9, 2012, 06:48 PM
Allstar
 
Join Date: Nov 2010
Location: London, Ontario
Posts: 644

My System Specs

Default

is the radiator mounted above the pump?
Reply With Quote
  #6 (permalink)  
Old January 9, 2012, 07:15 PM
Rookie
 
Join Date: Dec 2011
Location: CANADA !!!! (Ontario)
Posts: 22

My System Specs

Default

Using a corsair obsidian 650d case so yes, the radiator is mounted on the top of the case
Reply With Quote
  #7 (permalink)  
Old January 10, 2012, 07:15 AM
Slik's Avatar
Hall Of Fame
 
Join Date: Sep 2009
Location: Sault Ste Marie On.
Posts: 1,082

My System Specs

Default

Send it back and have it replaced. I have that cooler,and it runs dead quiet. It should be that way out of the box. No sense fooling around with it. RMA it ASAP.
__________________
Corsair Air 540 -i7 4930k @ 4.4ghz. Liquid cooled-4x4gb G Skill Trident X DDR3@ 2400mhz- Two EVGA Titans SLI - Xonar Phoebus Sound Card-Dell 3008 30" Monitor-Razer Tiamat Headphones-Butt Kicker Gamer-TrackIR 5
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Corsair H100 mardig88 Water Cooling 2 November 16, 2011 01:56 PM
H80 or H100 Reviews? PerryC Water Cooling 40 August 21, 2011 07:57 AM
120v outlet filter for noise, such a thing? (popping noise from speakers) On2wheels Troubleshooting 3 June 20, 2010 08:06 PM
Pump strange noise martin_metal_88 Water Cooling 5 June 17, 2010 08:17 AM
Swiftech H20-220C + Coolermaster CM690 = Pump Noise! Arrgh! Nate_The_Great Troubleshooting 2 January 22, 2008 12:58 PM