Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 4, 2011, 11:28 AM
Rookie
 
Join Date: Apr 2010
Posts: 14
Default BSOD after 5 minutes of turning on

Starting yesterday evening my main desktop crashed with a BSOD while I was in a game of SC2 with error code 0x000000F4. Previously the computer had been on for approximately 7 hours since I got home. Following this however, any attempt to turn on the computer results in a BSOD with the same error after ~5min of turning the computer on, and until the point it crashes it works fine. When it does crash, the system locks up for a second, cannot right or left click, then dwm.exe crashes as aero effects dissapear, then I regain control for a second, then BSOD.

I have opened up the memory dumps from each crash, and they all point to csrss.exe. My computer shows 2 instances of the exe running however showing the file location of each indicates that it is the legitimate windows process. (%Windows\System32).

My Build:
Windows 7 64-Bit
i7-930
P6X58D-E
WD 1TB WD1002FAEX
50GB OCZ Vertex LE
6GB OCZ Ram
HD5870 Vapor-X

It should be noted that I have the 1TB drive connected to the SATA3 port, and that the SSD is my boot drive, containing all programs. The system has not been overclocked and is just running on stock settings.

The memory dump is as follows:
CRITICAL_OBJECT_TERMINATION (f4)
A process or thread crucial to system operation has unexpectedly exited or been
terminated.
Several processes and threads are necessary for the operation of the
system; when they are terminated (for any reason), the system can no
longer function.
Arguments:
Arg1: 0000000000000003, Process
Arg2: fffffa8007a15980, Terminating object
Arg3: fffffa8007a15c60, Process image file name
Arg4: fffff80003182f40, Explanatory message (ascii)

Debugging Details:
------------------


PROCESS_OBJECT: fffffa8007a15980

IMAGE_NAME: csrss.exe

DEBUG_FLR_IMAGE_TIMESTAMP: 0

MODULE_NAME: csrss

FAULTING_MODULE: 0000000000000000

PROCESS_NAME: csrss.exe

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

BUGCHECK_STR: 0xF4_C0000005

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

CURRENT_IRQL: 0

STACK_TEXT:
fffff880`0aaac0e8 fffff800`032077d2 : 00000000`000000f4 00000000`00000003 fffffa80`07a15980 fffffa80`07a15c60 : nt!KeBugCheckEx
fffff880`0aaac0f0 fffff800`031b5bdb : ffffffff`ffffffff fffffa80`0838cb60 fffffa80`07a15980 fffffa80`07a15980 : nt!PspCatchCriticalBreak+0x92
fffff880`0aaac130 fffff800`03138838 : ffffffff`ffffffff 00000000`00000001 fffffa80`07a15980 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x179e6
fffff880`0aaac180 fffff800`02e7ef93 : fffffa80`07a15980 fffff800`c0000005 fffffa80`0838cb60 00000000`05b30a40 : nt!NtTerminateProcess+0xf4
fffff880`0aaac200 fffff800`02e7b530 : fffff800`02ecb6cf fffff880`0aaacb78 fffff880`0aaac8d0 fffff880`0aaacc20 : nt!KiSystemServiceCopyEnd+0x13
fffff880`0aaac398 fffff800`02ecb6cf : fffff880`0aaacb78 fffff880`0aaac8d0 fffff880`0aaacc20 00000000`05b322a0 : nt!KiServiceLinkage
fffff880`0aaac3a0 fffff800`02e7f382 : fffff880`0aaacb78 00000000`00013280 fffff880`0aaacc20 00000000`05b31d78 : nt! ?? ::FNODOBFM::`string'+0x49974
fffff880`0aaaca40 fffff800`02e7defa : 00000000`00000001 00000000`05b30ff8 00000000`779ce601 00000000`00013280 : nt!KiExceptionDispatch+0xc2
fffff880`0aaacc20 00000000`778c8c95 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x23a
00000000`05b31000 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x778c8c95


STACK_COMMAND: kb

FOLLOWUP_NAME: MachineOwner

FAILURE_BUCKET_ID: X64_0xF4_C0000005_IMAGE_csrss.exe

BUCKET_ID: X64_0xF4_C0000005_IMAGE_csrss.exe

Followup: MachineOwner

So far I have checked and reseated each connection in the computer, removed and reseated the RAM modules, and tested temperatures (core below ~45 even during crash).

If anyone has any suggestions then it would be greatly appreciated.

Much thanks in advance,
- Kazushi
Reply With Quote
  #2 (permalink)  
Old July 4, 2011, 11:30 AM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,607

My System Specs

Default

What's your power supply, it could have for some reason given up and 5 minutes its all i can give before it can't supply your system with steady power anymore.
Reply With Quote
  #3 (permalink)  
Old July 4, 2011, 11:40 AM
Banned
F@H
 
Join Date: Aug 2007
Location: mtl
Posts: 12,694
Default

put ubuntu or such o na dvd and see if it does it too?

check hw as per above if yes :)
Reply With Quote
  #4 (permalink)  
Old July 4, 2011, 12:01 PM
Rookie
 
Join Date: Apr 2010
Posts: 14
Default

Power supply is a Antec 850W, Model:CP-850. Will try a live CD when I return home from classes, and post my results.
Reply With Quote
  #5 (permalink)  
Old July 4, 2011, 02:38 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,970
Default

CSRSS Client/Server Runtime Server Subsystem may be a virus

power to HDD or data cable failed, check your connections if have another cable try it,

Last edited by KaptCrunch; July 4, 2011 at 02:46 PM.
Reply With Quote
  #6 (permalink)  
Old July 4, 2011, 09:03 PM
Rookie
 
Join Date: Apr 2010
Posts: 14
Default

I've checked the cable connections and replaced each, but it still BSOD. I did not use a linux live cd per say but I ran memtest86+ for 5 hours with no crashes, and no errors from memtest.
Reply With Quote
  #7 (permalink)  
Old July 5, 2011, 12:00 AM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 3,452

My System Specs

Default

Check this out I think that it just might be a software bug that is turning off that process which would give you the BSOD
Possible malware or virus maybe
windows - What does the csrss.exe process do? - Stack Overflow
Reply With Quote
  #8 (permalink)  
Old July 5, 2011, 12:38 PM
Rookie
 
Join Date: Apr 2010
Posts: 14
Default

So after running more tests with noting working, I used my Windows 7 Install DVD to be able to run CHKDSK on the drive, and it came back with thousands of bad sectors and an error (The disk does not have enough free space to replace bad clusters detected in file.........), with that occuring for almost every file. CHKDSK didn't even complete and ended halfway through with error code (6e74667363686b2e b34). Searching google led me to OCZ website itself, where a tech indicated the drive is dead. I have since requested and RMA from OCZ. So problem has beenn solved, just not in the way I was hoping it to.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer Freeze after running less than 3 Minutes. Pelt Troubleshooting 9 February 15, 2010 01:52 PM
pc turning on Phobia Troubleshooting 10 January 6, 2009 05:43 PM
Wireless speed drops after a few minutes after boot Zamundaman Networking 0 December 23, 2008 09:26 AM
New rig, games fatals after 5-15 minutes Ironmonk Troubleshooting 22 July 22, 2008 11:06 PM
pump not turning on? stormkiller22 Troubleshooting 8 April 4, 2008 02:17 AM