Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old March 17, 2011, 06:50 PM
punk_zappa's Avatar
Allstar
F@H
 
Join Date: Nov 2008
Location: Yellowknife
Posts: 965
Default ATI driver crash

A little of a head scratcher.

New rig,
X58 Sabertooth
6 GB Patriot Sector 7
ASUS HD6870
Antec 650W PS (old)
Windows 7 Ultimate 64-bit
Kingston 64GB SSD (old)

Everything stock. ATI driver kept crashing. First crash was within the first hour of fresh install and goes on 3 to 4 times everyday. WhoCrashed reported atimdag.sys is the culprit. Sometimes display will flicker and windows recovers (with message at the bottom) but most of the time it is just blue, white or purple screen even doing the simplest of tasks, internet browsing. Played a game for 2 hours straight or ran Furmark for an hour and no crash. Sometimes screen will go to solid color at boot and Windows welcome sound is still audible. I have this rig for a week now and only a day that it didn't crash, I am getting sick of trying anything else about the driver.

Old rig,
ASUS 785G
4 GB Patriot DDR2-800
and same everything

Fresh install to a Seagate 320GB SATA drive. It's been roughly 8 hours, constant restart, ran Furmark for an hour, no crashes or BSOD so far.

Could it be the SSD? Could it be the motherboard board? Could it be the RAMs? Could it be the power supply?

Throw in whatever you can think of.
__________________

Reply With Quote
  #2 (permalink)  
Old March 17, 2011, 06:53 PM
Hall Of Fame
F@H
 
Join Date: Feb 2010
Location: Markham
Posts: 1,566

My System Specs

Default

Are you running SP1? I've been having the same issue but I'm using an Nvidia card. Either the display driver crashes and recovers or I get a blank BSOD and the system hangs.
__________________
Reply With Quote
  #3 (permalink)  
Old March 18, 2011, 05:06 AM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,922
Default

Quote:
Originally Posted by punk_zappa View Post
A little of a head scratcher.

New rig,
X58 Sabertooth
6 GB Patriot Sector 7
ASUS HD6870
Antec 650W PS (old)
Windows 7 Ultimate 64-bit
Kingston 64GB SSD (old)

Throw in whatever you can think of.
can tell me what driver version for IDE/sata using in device manager

have you ran intel inf utility to get current chipset drivers

and what bios version your at? current is
Sabertooth X58 bios: 0802
1. Improve memory compatibility
2. Improve system stability
3. Fix Logitech G1 Keyboard may not be detected

other is realtek drivers lan audio

and your gpu i see two versions for hd6870






what version of card you got and check gpu bios is up to date for your graphics card version
Attached Images
 

Last edited by KaptCrunch; March 18, 2011 at 05:43 AM.
Reply With Quote
  #4 (permalink)  
Old March 18, 2011, 08:35 AM
punk_zappa's Avatar
Allstar
F@H
 
Join Date: Nov 2008
Location: Yellowknife
Posts: 965
Default

Quote:
Originally Posted by ilya View Post
Are you running SP1? I've been having the same issue but I'm using an Nvidia card. Either the display driver crashes and recovers or I get a blank BSOD and the system hangs.
Yes, so as the old rig but no crashes or hiccups so far.

@KaptKrunch
I haven't done any bios updates yet, I'd like to get it stable first. I am now thinking it is not the card. I will use this old one for a few days and see if it will crash if not then I will put the X58 back and do a fresh install.
__________________

Reply With Quote
  #5 (permalink)  
Old March 18, 2011, 12:49 PM
punk_zappa's Avatar
Allstar
F@H
 
Join Date: Nov 2008
Location: Yellowknife
Posts: 965
Default

Well, it crashed again. The card will be going back.
__________________

Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I update an ATI driver? NineLives Troubleshooting 3 August 25, 2010 01:16 PM
Ati Driver 10.3 Preview Ryoohki Video Cards 7 April 4, 2010 11:53 AM
ATI Catalyst Driver - Version 9.5 cadaveca O/S's, Drivers & General Software 15 May 25, 2009 02:27 PM
ATI/AMD driver stability cvmocanu Video Cards 4 August 13, 2008 03:20 PM
ATI Catalyst 7.12 Driver Released SKYMTL Press Releases & Tech News 0 December 20, 2007 06:34 PM