Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Anyone help a girl out, xfx radeon 4890 vid card can't seem to find driver (http://www.hardwarecanucks.com/forum/troubleshooting/40481-anyone-help-girl-out-xfx-radeon-4890-vid-card-cant-seem-find-driver.html)

whitelight February 3, 2011 11:39 AM

Anyone help a girl out, xfx radeon 4890 vid card can't seem to find driver
 
I was on here a year ago and got some great advice so I thought I'd try my luck again. Recently my motherboards network adapter died so ASUS replaced it but unfortunately my computer got reformated so I have to reinstall the drivers. I have a 4890 XFX Radeon video card but no matter what driver I install I always get a black screen after the windows prompt. When I load up again in safemode I can uninstall the driver but every version of driver that's suggested by the site keeps having the same issue. As a default it'll load up the VGA version most likely part of the motherboard but it looks like a retard screen and of course I can't play any games :(.
I have a 750 watt power supply and everything IS connected properly and I'm 99% positive that this is simply a driver issue, my frustration is stemming from the fact that ATI can't seem to keep it's drivers organized or in an easy to install and work format.

*- note I've had the same build for over a year and everything went off without a hitch then so i don't believe it's compatibility issues.

Anyfeed back is greatly appreciated

_dangtx_ February 3, 2011 11:45 AM

hey. well, when you install drivers the gpu will be able to ramp up to its clocks, so if the pci-express power

connector is not there it wont be able to work. can you check on that?

if not, then probably you need to use driver cleaner in safe mode, again.

are you getting the drivers from xfx's or amd's website?

AMD Graphics Drivers & Software

ATI Radeon

those are for windows 7 if you use another os you need to get the appropriate set.

how about this, if it stil ldoesnt work..


in safe mode, get Download | Ubuntu

and put it on a cd/dvd. after that, boot the computer with it.

if no issues, its just software. if issues, may be hardware related,again check the

power connector

whitelight February 3, 2011 11:59 AM

thanks for the reply :) Yeah I checked out the power connections and both PCI-E cords are plugged into the video card. I tried that site you posted and even tried multi versions going back to earlier ones and still the same issue. I'm trying it again version 11.1 to see if I have any luck, I'm no computer whiz but this has me really stumped

_dangtx_ February 3, 2011 12:03 PM

wait. you put ubuntu on a cd, you booted the pc with it and no issues? or issues?

shut down pc and disconnect your hard drive. then boot with ubuntu. see what gives.

also, is the card properly seated in the pci-e slot?

did you move your pc around, maybe from one room to the other?

Perineum February 3, 2011 12:07 PM

Sounds like a bent pin in the DVI connector to me.....

botat29 February 3, 2011 12:13 PM

I had the same problem with one of my monitor last year and a 4890, it's like the monitor can't detect if it's digital or analog and turn black and give the no signal message, what I did to solve it, was to use a very old driver from ATI. I don't remeber what I did to fix it for all, probably I switch the monitor to another PC



Quote:

Originally Posted by Perineum (Post 481780)
Sounds like a bent pin in the DVI connector to me.....


if it was so the monitor will not work at all....

Perineum February 3, 2011 12:18 PM

ah, no. The monitor may still work, but won't display higher resolutions. In my case I spent 2 days chasing this "bug" down and it was exactly that, a bent pin on the DVI connector. Lower res (like in safemode) would work, but anything over 1024x768 would flicker in and out and / or go black.

whitelight February 3, 2011 01:24 PM

yeah just remember that I have all the same hardware before the reformat and still have issues. Because the monitor worked before I see no reason why it wouldn't now. I checked all the hardware and I can't find any bent pins. I remember before I had to install an earlier version of the driver and that did solve the issue. However I've tried about 12 different versions all for Win 7 64bit OS and still no luck.

I have no idea what ubuntu is but I'm all ears, as of now I have a friend who's coming by and hopefully he'll figure it out. If this gets sorted then I'll message back what the problem was :) wish me luck

LarkStarr February 3, 2011 01:30 PM

prove you're a girl first!






Well, a simple check would be to swap the card to another computer with another monitor (and cable!), to check. isolate components. might be a bit of a pain.. I have a 4890, I've never had any problems with drivers and anything, straight from ATI/AMDs website. I don't know what you mean about disorganized.. I just download them and double click to install, it's pretty simple I thought?

_dangtx_ February 3, 2011 02:20 PM

lol dont swap anything.

ubuntu is an os, you can run from the cd and go on the internet with it etc or install

you dont want to install, rather run from cd.

if that one has issues too, its hardware related 100000%

does your frend, he/she know he/she is doing?


All times are GMT -7. The time now is 05:53 AM.