Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Running out of ram in Crysis (http://www.hardwarecanucks.com/forum/troubleshooting/24800-running-out-ram-crysis.html)

canmx120 October 25, 2009 06:19 PM

Running out of ram in Crysis
 
For some reason my OS(windows 7 professional) isn't releasing cached ram when it's needed. I have 4gb in my system, and I thought that should be plenty for now, but crysis in some parts is using about 2.4gb, and the os has around 1.3 in cache + whatever's left on background processes. Once the full 4gb gets used up, about 2-4minutes into gameplay from where I have my save, the system locks, and game crashes.
The part where it does it is on the aircraft carrier when your fighting the alien walker.
Can I manually set this cache to a smaller amount? I thought it was supposed to automatically release ram from cache when it is needed.

Thanks.

martin_metal_88 October 25, 2009 06:30 PM

Well, the best way IMO to fix this is to disable some of the windows feature witch are running and useless like turbo memory, If you are only using few software you don't really need it. if you have a router disable firewall and things like that. MSconfig can help you to find those, don't disable something you don't know what it is.

How to use MSCONFIG in Windows 7: NetSquirrel.com

There is many tweak like that but it's pretty weird that your windows wont free the ram itself.

Ask for more.

Silvgearx October 25, 2009 06:53 PM

i have never heard of crysis not getting enough ram. even if it does, doesn't the program just use what ever room is in the hard drive?

are you sure its not an overclock or ram timing error?

what was the BSOD.


Quote:

Originally Posted by martin_metal_88 (Post 277228)
Well, the best way IMO to fix this is to disable some of the windows feature witch are running and useless like turbo memory, If you are only using few software you don't really need it. if you have a router disable firewall and things like that. MSconfig can help you to find those, don't disable something you don't know what it is.
Ask for more.

I don't quite understand what your trying to say.

When i play games i usually disable all other applications and only have the network enable :bleh:

Ask for more.
:rofl:

Zero82z October 25, 2009 07:42 PM

You could try disabling Superfetch just to see if that's actually the source of the problem. Press Start, type in services.msc, and press Enter. Scroll down until you see Superfetch, right-click on it and select Stop. Give it a shot and see if the issue goes away.

Ask for more.

bojangles October 25, 2009 07:45 PM

How big is your pagefile?

Start -> Right click on computer -> Properties -> Advanced System Settings -> Advanced Tab -> Performance Settings -> Advanced Tab -> Virtual Memory

Perineum October 25, 2009 08:01 PM

I'm betting it's nothing to do with ram.

Silvgearx October 25, 2009 08:20 PM

Quote:

Originally Posted by Perineum (Post 277278)
I'm betting it's nothing to do with ram.

+1

Ask for more.
:haha:

canmx120 October 25, 2009 08:20 PM

Ok, disabled super fetch, didn't see anything in msconfig called turbo memory.
I set my page file to 4gb up from what it was(can't remember what it is default), a few days ago hoping that would free up some ram but it didn't seem to have any effect. I'll see if having super fetch off helps.
Thanks for all of the fast replies, its nice to know when you have an issue you can get help here so quickly.

Arinoth October 25, 2009 08:21 PM

Are you running the latest patch for it and drivers for your video card. Could be a memory leak (patches typically fix this)

Ask for more

DenisS October 25, 2009 08:33 PM

Asking for more :haha:


All times are GMT -7. The time now is 06:17 AM.