Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 4, 2009, 04:38 PM
Rookie
 
Join Date: Apr 2009
Location: GTA
Posts: 45
Default What's The Bottleneck On This Older Rig?

Hi dudes,

I'm using a friend's PC here, and all works well, except...

PC is used largely for browsing, e-mail, older games (AoEIII, World Of Goo, so nothing terribly taxing). Hardware is older:

- P4 3.00GHZ (device manager shows two CPUs, so dual-core?) It's about 6 years old.
- 2GB RAM (maxed)
- Radeon 9600 Pro 256MB

Everything runs without difficulty, except for these two: unRARing a torrent (>/<4.25GB) takes an agonizing 45 minutes(!!). Burning the resultant ISO at max speed takes the same amount of time. My crappy old Dell Inspiron, spec'ed lower than this box, unRARed in 4 minutes flat, burnt the ISO in 15 minutes at 4x spped. Also, movies played using Power DVD run in a choppy fashion.

AVG shows no viruses. Malwarebytes reports no problems. Both HDDs have been de-fragged. I ran CC Cleaner last night. PC was re-formatted roughly 11 months ago, and was just as slow performing these tasks when freshly formatted as it now. So what's the bottleneck here?





Thanks for reading, and thanks for any help. Cheers.

DS.

Last edited by Dave Simpson; August 26, 2009 at 02:16 AM.
Reply With Quote
  #2 (permalink)  
Old August 4, 2009, 04:44 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,604

My System Specs

Default

He does but he doesn't have 2 cores. P4 was the first processor to implement hyper threading, which is an intel technology used to improve parallel computations. A processor with hyper threading enabled it is treated by the OS by having 2 processors instead of one.

You mentioned it takes a while for him to burn a DvD, it could be that the burning speeds (seeing as it is 6 years old and may have been a low quality burning to begin with) could be x2 times which is rather slow. It could also be both those devices are connected not with the faster SATA connection, but rather IDE (or PATA) which is a physical hardware bottleneck there.

Graphics card will not bottleneck a system if it is not being used, and you mention the bottleneck is happening cpu side. Potentially the CPU is running rather hot, or there could be a lot of dust on parts. Dust in fans or on the mobo/components will cause slow down as well the thermal paste that is on the heat sink could have dried up causing the cpu to heat up as well.

Last edited by Arinoth; August 4, 2009 at 04:49 PM.
Reply With Quote
  #3 (permalink)  
Old August 4, 2009, 05:03 PM
Caldezar's Avatar
Hall Of Fame
F@H
 
Join Date: Aug 2008
Location: Burnaby
Posts: 1,731
Default

I'm gonna take a one-shot here and say the slow burning is very likely because the drive is set to PIO mode. This happens a lot with IDE drives on older systems. To check if this is the issue, go to the device manager, go to the properties of the IDE Channel that the burner is on (IDE channel 0 likely?) and check in the advanced settings? tab to see if it's in PIO mode. If this is the case, switch it to Ultra DMA 4.
Reply With Quote
  #4 (permalink)  
Old August 4, 2009, 05:04 PM
Rookie
 
Join Date: Apr 2009
Location: GTA
Posts: 45
Default

Thanks for the reply, Arinoth.

The DVD drive itself is about 3 years old; all drives are indeed IDE, not SATA. Even so, my old Dell rig, referenced above and also all IDE, performed these tasks waay faster.

Asus Probe says the CPU is running at 45C, and "OK", even though I'd say that's a little on the hotter side. PC was taken apart and blown with low-pressure air last night. Dust OK.

I'm really stumped here. Cheers.

DS.
Reply With Quote
  #5 (permalink)  
Old August 4, 2009, 05:11 PM
Rookie
 
Join Date: Apr 2009
Location: GTA
Posts: 45
Default

Thanks, Caldezar. Primary IDE channel details: Device 0, Ultra DMA Mode 5, Device 1, DMA if available, current Transfer Mode, PIO. Can't change it to DMA. Secondary IDE Channel, Device 0 and Device 1, both Ultra DMA Mode 2, can't change 'em.

Cheers.

DS.

Last edited by Dave Simpson; August 9, 2009 at 07:36 PM.
Reply With Quote
  #6 (permalink)  
Old August 4, 2009, 05:12 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,604

My System Specs

Default

Just a heads up i should have mentioned with my original post, i can only see 2 of the pictures you have in your main post and no more
Reply With Quote
  #7 (permalink)  
Old August 4, 2009, 05:15 PM
Rookie
 
Join Date: Apr 2009
Location: GTA
Posts: 45
Default

Excuse my poor formatting; there are only two images to see.

DS.
Reply With Quote
  #8 (permalink)  
Old August 4, 2009, 07:10 PM
3 of 7's Avatar
Allstar
 
Join Date: Nov 2008
Location: Nanaimo BC
Posts: 919
Default

Quote:
Originally Posted by Dave Simpson View Post
Thanks, Caldezar. Primary IDE channel details: Device 0, Ultra DMA Mode 5, Device 1, DMA if available, current Transfer Mode, PIO. Can't cahnge it to DMA. Secondary IDE Channel, Device 0 and Device 1, both Ultra DMA Mode 2, can't change 'em.

Cheers.

DS.
Looks like the HD is in PIO mode, Simple fix, uninstall it from hardware manager and reboot. XP will reinstall it automatically.
__________________
Nature always sides with the hidden flaw
Reply With Quote
  #9 (permalink)  
Old August 6, 2009, 07:49 PM
Rookie
 
Join Date: Apr 2009
Location: GTA
Posts: 45
Default

There are two HDDs in this box. Drive C is for XP and apps, drive D has everything else, including RAR files and ISOs. Which one to uninstall? Or is it both? And will they really be safely re-installed upon re-boot? I'm pretty hesitant to do this to somebody else's PC.

Thanks!
Reply With Quote
  #10 (permalink)  
Old August 6, 2009, 08:43 PM
grinder's Avatar
Allstar
F@H
 
Join Date: Mar 2007
Posts: 823

My System Specs

Default

must be an SiS chipset =P what mobo is it?
__________________
Phenom II 945 :: ASUS M4A78-E (780G) :: BFG 285GTX :: 4GB Mushkin DDR2 (5-4-4-12) :: Creative Xi-Fi :: Seagate 500 gig 7200.12 (better than WD BLACK!!!!!) :: Samsung 2493HM
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Conveting an older pc into a HTPC Shadowmeph HTPC Systems & Software 10 May 2, 2009 10:50 PM
4870x2 bottleneck kyle_L Video Cards 8 February 25, 2009 07:07 PM
Need assistance for my older system!! p3dro Troubleshooting 11 February 11, 2009 02:34 PM
[WTB] Older Pentium M cpu's mklym Buy/Sell & Trade 2 January 11, 2009 09:19 PM
Can't read older cds no_pulse Storage 1 December 13, 2008 07:42 PM