Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 15, 2009, 12:56 PM
odis172's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Ottawa, ON
Posts: 682

My System Specs

Default laptop display issues

HP dv9854ca
8600m video (built into the same pcb as mobo)
17''
4 gigs ram.

Im working on a laptop with a peculiar problem.
The system had fresh installed a copy of vista 64, all drivers installed by a fellow tech and given to me to finish. What its doing is when you boot into windows, its set to 4bit color and a low resolution, also theres some strange black patters on the screen. Safe mode looks ok (low res though), and Vga mode looks the same as safe, there is a yellow exclamation mark in the device manager almost as if the driver isnt installed. I have installed the correct drivers, still the problem persists. I have cold booted it about 8 times, during looking at it, no change. It sat on my desk for a day then I started tearing it apart. After taking out the wireless card, hd,ram, i thought i should just check once more to be doubly sure. Sure enough it booted up fine into windows fine, with a high res, great color, and device manager reported there were no issues. I suspect theres something wrong with the hardware, and putting pressure on the motherboard to remove the wireless card's screws did something to it. So i shut it down, and dropped it a few times onto the top and bottom from about 4 inches up. After starting it up (having to do a startup repair first _ it went into windows with the same issue as before - looks like I prevoked the issue with some physical jarring. I suspect theres something wrong with the gpu's higher functions - it can display basic video and thats it.

So before i order a new motherboard I would like some second opinions.
Thx!
__________________
Laptop: Lenovo T420 - Core i5 2520 - 8GB DDR3
Server: 2 xeon E5530 - Asus Z8N-D6 - 12GB DDR3 - 8x 500GB raid 50 - Perc 6/i - Compucase RA448A00
Reply With Quote
  #2 (permalink)  
Old July 16, 2009, 01:51 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,223

My System Specs

Default

Quote:
Originally Posted by odis172 View Post
So i shut it down, and dropped it a few times onto the top and bottom from about 4 inches up.
Not something you want to say in public before thinking of returning it to manufacturer

I remember that nVidia G84 and G86 (8600M and 8400M, respectively) had overheating problems, causing Dell to extend warranties and release BIOS updates to increase cooling to the GPU. You could try a BIOS update to see if that fixes it.

It may be the defective GPU - if you can get the computer back into the state where graphics appear to display properly, you should try to run a GPU test (e.g. Furmark) and see what happens. Can you also try a different OS (e.g. whatever came with the laptop or was in the restore partition)? See if you can get a different OS (even try Linux) to display your laptop's native resolution.
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #3 (permalink)  
Old July 16, 2009, 05:36 PM
Hall Of Fame
F@H
 
Join Date: Jan 2008
Location: AB
Posts: 1,212
Default

Try downloading a live version of ubuntu, burn it to a disc, pop it in the disk drive and fire up the laptop. if when its done loading, your video still looks whacked, then perhaps its a hardware issue.
__________________

vista 64 on these rigs
Q9450 @ 3.5Ghz | E8400 @ 4.2Ghz
8gb Muskin Redline. | 2gb Kingston Hyperx
________________________________|_________________ ______________
EVGA 780i FTW ----\--||___||--/---- EVGA 780i SLI
Antec TP Quatro 1000W \ :==^==: / Antec TP Quatro 850W.
Nvidia 9800 GX2 X 2 SLI \|--o--|/ Nvidia 8800 GTS X 2 SLI
1X 500GB Western Digital. \_____/ 3X 150GB WD RAPTOR RAID-0
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
MAC DDR laptop mem in an Intel based laptop? sswilson RAM 6 June 2, 2009 12:30 PM
New PC No display! Pokeguylow Troubleshooting 7 May 3, 2009 09:33 PM
Display Problems Samael Video Cards 0 April 1, 2009 11:09 AM
Display Questions RJones Display Units 8 November 28, 2008 07:19 AM
Looking for a good primer on vid card settings & display issues sswilson Video Cards 6 November 2, 2008 09:21 AM