Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #161 (permalink)  
Old August 16, 2011, 05:29 PM
Alpine's Avatar
Allstar
 
Join Date: Dec 2008
Location: Boucherville / South shore of MTL
Posts: 864

My System Specs

Default

Company Name:OCZ
Product: SSD Solid 3 60GB # SLD3-25SAT3-60G
Warranty Period: can't remember, something like 3 years
Date purchased: May 27 2011
Date RMAed: August 5 2011
Where it was sent to: Markham Ontario
Ease of RMA: 9
Any extra fees?: 12$ for shipping
Wait time: 7 days
Details: Everything was good. I think they didn't test anything. I got i proof that they have receive it like at 11 am and then, i have receive a email 15 mins later with a tracking #.
Satisfaction: 10
__________________
Main system
|I7 3930K|Asus P9X79 WS|Evga GTX 690 Signature|Samsung 256G Pro|Corsair H100|Dominator Platinium 16GB 2133Mhz|
Corsair AX1200|Corsair 540 AIR|Corsair SP2500|Corsair Vengeance 2000|
Server system
|I7 3820|Asus P9X79|12G G.Skill 1600Mhz|Noctua NH-D14|Corsair Force 3 120GB|LSI megaRAID 9261 8|RAID5 5X 3TB|Corsair AX650|Fractal Design Arc Midi|

Twitch
Reply With Quote
  #162 (permalink)  
Old August 17, 2011, 06:57 AM
Trial Member
 
Join Date: Aug 2011
Posts: 1
Default

Company Name: NCIX
Product: Gigabyte Z68, G. Skill Ripjaws, i5-2500k
Warranty Period: 30 days return period.
Date purchased: June 30, 2011
Date RMAed: July 20?, 2011
Where it was sent to: Richmond, BC
Ease of RMA: 10
Any extra fees?: No
Wait time: about one week
Details: Got bsod from the get go, worked with their tech trying to solve it but no solution. Was very frustrated at one point and blew up when I misread a CS reps email. After it was returned and tested it looks like a compatibility issue ("each part worked well individually, but not when we put it together".) I'd beware of those Ripjaws, seems every time I hear someone is having bsod, they also have S. Skill ram.
Satisfaction: 10, paid shipping as well.
Reply With Quote
  #163 (permalink)  
Old August 17, 2011, 03:35 PM
Keywork's Avatar
Allstar
 
Join Date: Jun 2009
Location: Niagara
Posts: 604

My System Specs

Default

Company Name: HP
Product: EliteBook 8530P
Warranty Period: 3 Year Global
Date purchased: ~1.5 years ago
Date RMAed: Couple weeks ago
Where it was sent to: Markham, Ontario (I think)
Ease of RMA: 10
Any extra fees?: None
Wait time: 4 Days
Details: HP's support for their high end products is incredible. Called inquiring about graphics card issue. They overnighted me an empty box with a shipping label on Monday. Sent it out and had it fixed and at my
door on Friday. Top notch service!!
Satisfaction: 10
Reply With Quote
  #164 (permalink)  
Old August 17, 2011, 11:31 PM
Allstar
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 724
Default

Company Name: Crucial Memory
Product: Ballistic DDR2 (4 GB)
Warranty Period: Limited life time
Date purchased: given to me about 1.5 years ago
Date RMAed: 1 week ago
Where it was sent to: ID, USA
Ease of RMA: 10
Any extra fees?: None, just shipping from my side
Wait time: 1 week including shipping to them
Details: RMA request was within 48 hours via their website. I shipped it last week via Canada Post ground and took about 3 days to get there. Today (1 week later), I get an email from Crucial saying the replacement is out the door. Check the UPS and they used 1 day express shipping and it's sitting in Richmond already!
Satisfaction: 10
Reply With Quote
  #165 (permalink)  
Old August 17, 2011, 11:49 PM
Allstar
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 724
Default

Company Name: OCZ
Product: Reaper DDR2 (4 GB)
Warranty Period: limited life time
Date purchased: 2-3 years ago?
Date RMAed: can't remember (did it 2/3 times)
Where it was sent: some where in USA
Ease of RMA: 8
Any extra fees?: none beside shipping
Wait time: 2 to 3 weeks
Details: I had to RMA the RAM about 2 to 3 times. Initial purchase from NCIX was fine and suffered problems after 8 months or so. Replacement RAM lasted also 8 months before failing MemTest. Once again, I sent the unit in at my expense. The RAM came back faulty and I asked OCZ to pick up the shipping cost, which they did. However, once again the replacement unit came back faulty and I gave up on OCZ completely. It appears that they don't even bother testing their stuff before sending them out the door.
Satisfaction: 3
Reply With Quote
  #166 (permalink)  
Old August 18, 2011, 08:16 AM
Rookie
 
Join Date: Jul 2009
Posts: 22
Default

Company Name: Kingston Technology
Product: 64GB SSD 100V
Warranty Period: 3 year
Date purchased: April 2011
Date RMAed: Aug 10, 2011
Where it was sent to: Forest City Calif
Ease of RMA: 8 (no Fedex within 20km, kind of a hassle finding one too)
Any extra fees?: They paid International Economy there, and International Express return.
Wait time: One week from sending to return
Details: Drive scrambled Windows 7 twice, put in an RMA. Was approved two days later. They paid shipping but only from a depot not pickup which is great if you live near a depot, I don't. Had to make two trips (total of 40km) to get it sent. The RMA itself was painless, but they don't tell you they're sending it or provide a tracking number unless you ask.
Satisfaction: 9
Reply With Quote
  #167 (permalink)  
Old August 22, 2011, 11:17 AM
Rookie
 
Join Date: Jul 2009
Posts: 22
Default

Company Name: Kensington
Product: Power Adapter for Netbooks
Warranty Period: 2 year
Date purchased: April 2009
Date RMAed: April and Aug 2011
Where it was sent to: no return
Ease of RMA: 10
Any extra fees?: none
Wait time: One week
Details: First power adapter failed in April, contacted them and they sent a new one a week later. Don't want the old one back. Second one failed in July, contacted them and they asked for a receipt I no longer had. Didn't get back to them. They apparently closed the case number but I received another number and they said they'd send me one. Got it today.
Satisfaction: 10
Reply With Quote
  #168 (permalink)  
Old October 14, 2011, 10:30 AM
Slaughter's Avatar
MVP
F@H
 
Join Date: Nov 2010
Location: Toronto, ON
Posts: 351

My System Specs

Default

Company Name: MSI
Product: N560GTX-Ti Twin Frozr II/OC
Warranty Period: 3 year
Date purchased: December 2010
Date RMAed: October 14, 2011
Where it was sent to: Dropped off @ Markham Depot (361 Alden Road)
Ease of RMA: 10
Any extra fees?: None
Wait time: 10 Minutes
Details: Brought the card in to drop it off at the Markham depot. I was asked to wait a minute while they generated a receipt. While waiting, I received an email on my phone stating that it was received and two minutes later that a replacement was shipped. He then came out with a replacement card in hand. Couldn't have been any better!
Satisfaction: 10+
Reply With Quote
  #169 (permalink)  
Old November 29, 2011, 01:35 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,637

My System Specs

Default

Quote:
Originally Posted by Slaughter View Post
Company Name: MSI
Product: N560GTX-Ti Twin Frozr II/OC
Warranty Period: 3 year
Date purchased: December 2010
Date RMAed: October 14, 2011
Where it was sent to: Dropped off @ Markham Depot (361 Alden Road)
Ease of RMA: 10
Any extra fees?: None
Wait time: 10 Minutes
Details: Brought the card in to drop it off at the Markham depot. I was asked to wait a minute while they generated a receipt. While waiting, I received an email on my phone stating that it was received and two minutes later that a replacement was shipped. He then came out with a replacement card in hand. Couldn't have been any better!
Satisfaction: 10+
Did you do up an RMA request through their website? If so, how long did it take for them to aprove it?
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 4G Gskill 1866 DDR3 / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / random 160G Sata HDD
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 320G Seagate Momentus / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #170 (permalink)  
Old November 29, 2011, 01:45 PM
Slaughter's Avatar
MVP
F@H
 
Join Date: Nov 2010
Location: Toronto, ON
Posts: 351

My System Specs

Default

Quote:
Originally Posted by sswilson View Post
Did you do up an RMA request through their website? If so, how long did it take for them to aprove it?
Yes, I did request it through their website (which isn't the easiest site to navigate) and had a response within 24-48 hours at the very most.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canadian EH? Supergrover Off Topic 13 June 10, 2008 12:05 PM
My Experience with Direct Canada spdracer Off Topic 7 December 31, 2007 12:41 PM
Poor 1st o/c experience leads me to build dedicated o/c rig, help decide donimo Overclocking, Tweaking and Benchmarking 18 December 13, 2007 08:43 PM
Anyone have experience with Intel server boards? Jack Rabbit CPU's and Motherboards 20 November 26, 2007 08:31 PM
Initial experience very poor, not impressed. Chrisahl Off Topic 13 August 2, 2007 12:09 PM