Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   sata hard drive formatting issue in XP (http://www.hardwarecanucks.com/forum/troubleshooting/10653-sata-hard-drive-formatting-issue-xp.html)

sirhc October 7, 2008 10:12 PM

sata hard drive formatting issue in XP
 
Just received my parts for my new build, got it all assembled and set the bios up? went to install XP and it needed to format my 500gb sata hard drive and after 40 minutes it came back saying it could not do it .. to full or damaged or?? Bad hard drive? That would suck another 3 week wait! Any ideas? I did not use the f6 because the bios saw my hard drive???

arekieh October 7, 2008 10:45 PM

Hey man,
Dont give up, before you do try formatting with a live linux cd like gparted. Its basically a linux kernel thats solely for editing partitions and formatting drives. Handy program.
GParted -- Welcome

If that doesnt work, i would send the drive in for an RMA
Good luck

Squeetard October 7, 2008 11:19 PM

Did you set your sata as IDE and not RAID in the bios?

enaberif October 7, 2008 11:53 PM

Did you do a full format or a quick format?

Full format does a check of the disk to confirm everything is good. If this fails then generally there is a problem with the drive.

sirhc October 8, 2008 04:19 AM

first build issues with sata and XP
 
I will confirm but pretty sure it was set as raid and not ide and did the full not the quick .... ordered from NCIX will local Computer stores replace the drive for me or does it have to go back to NCIX?

Tazer-[X] October 8, 2008 04:25 AM

Well, you could always forget about all the neato little apps and stuff and go back to basic, get a win98 start up disk. sounds strange, but, its bout the best tool ive ever had to scramble for.

sirhc October 8, 2008 05:12 AM

in the bios it says "sata ahci" => should this be enabled or disabled when plan is to use XP?

also "sata port 0-3 native mode" => should this B enabled or disabled?

I disabled the serial and parralel ports

what about the onboard IDE controller?

The hard drive shows up under IDE channel 0 master and the CDROM shows up under IDE channel 1 master ... ??

Any ideas as to what they should show as?

sirhc October 8, 2008 06:14 AM

in the bios it says "sata ahci" => should this be enabled or disabled when plan is to use XP?

also "sata port 0-3 native mode" => should this B enabled or disabled?
Originally I had these set to disabled because I read somewhere that XP has a problem with sata drives and the bios detected both my DVD rom and HD, I tried switching to AHCI and enabled and my bios did not find my harddrive and DVD rom?

The problem was that XP could not format my 500 GB HD ... I was only using a single partition "C" I am guessing it is a bad hard drive .... how can I be sure?

arekieh October 8, 2008 06:46 AM

As i said, run gparted
and try formatting it with it. Gparted has fix many "ruined" drives for me

Mr. Gruntsworthy October 8, 2008 07:30 AM

he said that it was set to RAID.


All times are GMT -7. The time now is 11:16 PM.