Go Back   Hardware Canucks > HARDWARE > Storage

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 21, 2013, 05:39 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default WD Black bad sectors +1 every few months

Hi all,

Do I have a drive that's "aging" or dying?

One of my Linux boxes has a 1TB WDC WD1002FAEX, and I notice that the bad sector count goes up by exactly 1-2 every so often. "Every so often" started as ~1 year (0 to 1, then to 3), but now I'm at 3 reallocated sectors with 1 pending.

The attributes of the HDD are currently:
Code:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       41
  3 Spin_Up_Time            0x0027   172   169   021    Pre-fail  Always       -       4383
  4 Start_Stop_Count        0x0032   098   098   000    Old_age   Always       -       2658
   5 Reallocated_Sector_Ct   0x0033   199   199   140    Pre-fail  Always       -       3
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   070   070   000    Old_age   Always       -       21937
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       1443
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       452
193 Load_Cycle_Count        0x0032   200   200   000    Old_age   Always       -       2205
194 Temperature_Celsius     0x0022   112   098   000    Old_age   Always       -       35
196 Reallocated_Event_Count 0x0032   198   198   000    Old_age   Always       -       2
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       1
198 Offline_Uncorrectable   0x0030   200   200   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x0008   200   198   000    Old_age   Offline      -       101
After smartd alerted me to the bad sector, I ran both SMART tests and they pass:
Code:
1  Extended offline    Completed without error       00%     21932         -
2  Short offline       Completed without error       00%     21925         -
Should I move the stuff to another hard drive? (If I lost the drive completely there'd be some but no )

Thanks!
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #2 (permalink)  
Old December 21, 2013, 07:40 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,929

My System Specs

Default

Typically between the file system and the disk firmware itself, it should be able to recover from failed sectors (as it seems to be doing just fine). You'll eventually start to lose capacity though I believe.

You should probably consider replacement sooner than later, or at least keep backups of important data on the drive.
Reply With Quote
  #3 (permalink)  
Old December 21, 2013, 08:38 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

Thanks for the reply! I've been looking for an excuse to try newer HDDs, so maybe this is it. Hopefully there's something good in the boxing day, or post-CES (a.k.a. January clearout).

Why does Murphy have to get my good drives... I have some very slow 160GB, 250GB, 320GB, 360GB, and 500GB drives that I'd much rather see dead than this one.
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #4 (permalink)  
Old December 22, 2013, 09:42 AM
Rookie
 
Join Date: Dec 2013
Posts: 2
Default WD HDD Bad Sectors

I recently had the same issue. I went onto the WD site hoping the drive (WD 2TB Black) still had some warranty left on it. The skies opened and my warranty would not expire until 5 Jan 14. Did an RMA and got a brand new WD 2TB Black (latest edition) as a free upgrade replacement. Check their warranty search site - well worth it.

have a Merry Xmas.
Reply With Quote
  #5 (permalink)  
Old December 22, 2013, 07:26 PM
Shadowarez's Avatar
Allstar
 
Join Date: Oct 2013
Location: Arctic Canada
Posts: 668

My System Specs

Default

If you need a reliable drive the wd reds are really nice got a few 3TB reds in my network.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Next 6 months in the SSD market Mayjaplaya Storage 3 November 14, 2013 06:24 PM
[FS] i5 2500k ( Less than 2 months old) cruisx Buy/Sell & Trade 3 December 18, 2011 03:39 PM
Gallery What have you done in the last 8 months ? BrainEater Case Mods, Worklog & Gallery 25 October 11, 2011 06:05 PM
h50 rad after a months use severity Water Cooling 16 April 6, 2011 09:26 PM
Bad Sectors DenisS Storage 22 December 8, 2009 07:23 AM