Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Storage (http://www.hardwarecanucks.com/forum/storage/)
-   -   OCZ Agility 3 SSD - To Rma or not to Rma? (http://www.hardwarecanucks.com/forum/storage/57736-ocz-agility-3-ssd-rma-not-rma.html)

igot6strings November 6, 2012 09:28 PM

OCZ Agility 3 SSD - To Rma or not to Rma?
 
Been having some issues with my drive lately. I attempted to update the firmware but it fails. I am also having lock ups when I use the drive for gaming. Its only a 60gb drive so I don't have many games on it except the ones I play most often. My system locks up solid when the games load, not all the time maybe 1/10 times but if its the drive and its on the way out I'd rather RMA while I can. I've had it for about 6 months or so. I know these drives don't have the best rep but am unsure what I should do.

Is there a good diagnostic I can run to see if the drive is still good? I have no clue about SSD drives or any storage device really.

bigFOIG November 7, 2012 01:48 AM

If you decide to RMA it, do it before they go bankrupt! :whistle:

bigFOIG November 7, 2012 01:50 AM

Try downloading a free program that checks the S.M.A.R.T Status of your SSD and see if there are any errors. I can't think of one right now off the top of my head though...

On the Lam November 7, 2012 04:42 AM

Try SSDlife Free - I'm not sure if it will tell you much, but give it a shot.

igot6strings November 7, 2012 05:32 AM

Speedfan has a S.M.A.R.T. test. I ran the extended test and it gave no errors.
Results are here:
HDDStatus - Tool to check hard disk status, health and reliability

So I'm assuming now the issue isnt the drive but something else? I have no issues with my system currently besides the lock up when running games off this drive. Is there something else that could be causing the lock ups? RAM and CPU are fine when I run Prime95. Only other culprit i can think of would be the GPU but that seems to do fine when folding. I guess I'll have to run some intensive tests on my gpu to see if thats the issue.

bigFOIG November 8, 2012 01:28 AM

I still think it's the SSD. Especially if you can't update the firmware on it for some reason. I would think that it's an SSD firmware issue that could be fixed by updating the firmware, but since you can't do that, I would RMA it just for that reason. Also, are you trying to update the firmware on your SSD while you're running Windows on it? I remember having to boot off a separate hard drive in order to update the firmware on my Vertex 3.

igot6strings November 8, 2012 03:27 AM

Yes i am trying to do so while running windows but windows is not on the drive, windows is on my HDD. The ssd is only 60gb so its only used for a handful of games. I'll try popping it in my htpc and see if I can update the firmware there just incase though.

bigFOIG November 8, 2012 04:01 PM

It should've worked if your OS is on a different drive. I would just RMA it. 8)

igot6strings November 8, 2012 04:55 PM

I managed to get the update to work by using the linux boot utility they provide. It ran off a usb stick so it was a rather simple process. The toolbox updater worked perfectly in the linux utility. It took a matter of seconds to complete where as in W7 it hung for 3 or 4mins before failing. I'm thinking a program or possibly windows had it locked down and wouldn't allow the update. I have only steam games on there so maybe it was the steam service. I tried in safe mode but no dice. Thank god for the linux utility. Still not sure if my system will freeze yet its only been a day but so far its been going smooth.

bigFOIG November 9, 2012 02:05 AM

I used to get lock ups as well with my OCZ Vertex 3, but not just during gaming. It was completely fine. After a firmware update, it's been fine for almost a year now. Hopefully same goes with yours.


All times are GMT -7. The time now is 12:37 PM.