Go Back   Hardware Canucks > HARDWARE > Storage

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 14, 2009, 09:05 PM
automatic's Avatar
Rookie
 
Join Date: Sep 2008
Location: White Rock
Posts: 40
Default My External HD is not detecting properly.

I have a Seagate Free Agent Go 250GB. I purchased it roughly 3 months ago.

I plugged my external HD into my computer for the first time in 3 weeks (Last thing I did was delete the folder that contained all of my files) and it did not appear in My Computer next to the (C:) drive like it usually does. It was detected by 'Safely Remove Hardware' and Seagate Manager when I connect it but I cannot open or explore within the drive. I took some screen shots because I'm not the best at explaining my technical issues.

http://i30.tinypic.com/27zklmf.jpg
http://i26.tinypic.com/20gjz6.jpg
http://i27.tinypic.com/73p1sw.jpg

Now I followed some troubleshooting suggestions from the Seagate website.
- I've attempted to format, delete and assign a letter to the partition/volume and got the same error message: http://i30.tinypic.com/2a7stft.jpg (I've tried restarting)
- I tried using multiple usb connectors
- I'm pretty sure it is not a power supply issue (I've tried USB ports on the back and front of my computer)
- I have not tried plugging my external HD into another computer yet, however I plan to try this soon.

Ask away if you need any more specifics inorder to help me and I'll do what I can to explain.

Your help is greatly appreciated.


edit:
I should have put this in Troubleshooting, whoops!

Last edited by automatic; July 14, 2009 at 09:45 PM.
Reply With Quote
  #2 (permalink)  
Old July 14, 2009, 09:29 PM
automatic's Avatar
Rookie
 
Join Date: Sep 2008
Location: White Rock
Posts: 40
Default

Bump!

Last edited by automatic; July 14, 2009 at 09:44 PM.
Reply With Quote
  #3 (permalink)  
Old July 18, 2009, 10:58 AM
JimboToronto's Avatar
Top Prospect
 
Join Date: Jul 2009
Posts: 173

My System Specs

Default

From what I see from the screenshots of Device Manager and Disk Management, your portable HDD is recognized and the correct partition size reported, but not the file system.

Have you tried simply reformatting in NTFS? I hope all the data is backed up elsewhere. If not, have you tried it in another system to see if the filesystem is recognized?

The big question is why it became corrupted in the first place. Heat? Power issues? Physical trauma?

Or just good old-fashioned user error?

Maybe it was just a lemon to begin with and the timing of the failure was coincidental.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get FLAC files to work properly biff HTPC Systems & Software 4 March 15, 2009 09:31 AM
properly install win xp sp3 pro CTA O/S's, Drivers & General Software 11 August 26, 2008 10:53 PM
Doing Mushkin rebate Properly. Dashock Off Topic 3 August 18, 2008 04:44 AM
Webcam not working properly Kentalish Peripherals 3 July 26, 2008 02:45 AM
How to properly apply thermal compound Corpus Masochist CPU's and Motherboards 9 August 11, 2007 08:12 AM