Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Storage (http://www.hardwarecanucks.com/forum/storage/)
-   -   SATA DVD Drive Problem (http://www.hardwarecanucks.com/forum/storage/12041-sata-dvd-drive-problem.html)

rjbarker November 21, 2008 12:15 AM

SATA DVD Drive Problem
Hey all,
Over the past 5 days or so I have installed new SATA HDD and reinstalled my OS on that Drive...everything went fine. PC has been running great. However, pretty much "all of a sudden" when I insert a game DVD into my Asus DVD ROM Drive (SATA), such as COD4 or COD WaW...the game title screen shows up, I select Single Player, the little LED Lt on my Drive flickers, then a wWindow pops up stating" Cannot Locate The DVD ROM - Select OK and Re-start Application"...

Even if I try to open the Application utilizing the Short Cut on my Desktop I will still get this same Window pop-up.
I can play a DVD Movie in the Drive, but no go on a game.

I have tried re-seating my SATA Cables and Power Cable, even swapping the SATA Cable and trying in other SATA Ports.

Could this be my DVD ROM Drive going caput?.....Everything fine on my LG IDE DVD RW Drive.

Thanks in advance

Squeetard November 21, 2008 12:18 AM

Nope, it's secure rom DRM causing that. I got the same crap. Found a crack rather than deal with it.

rjbarker November 21, 2008 12:35 AM


Nope, it's secure rom DRM causing that. I got the same crap. Found a crack rather than deal with it.
How do you mean Squeetard?......sorry...not following you.

sswilson November 21, 2008 04:11 AM


Originally Posted by rjbarker (Post 115603)
How do you mean Squeetard?......sorry...not following you.

It's the copyright protection on the disk that's doing it. SecureRom is a POS.

Are you running anything like Daemon tools?

What Squeetard is suggesting is that (like with many DRM games) you're going to have to risk the security of your system by finding a third party solution to get around the DRM on a game you've paid good money for.

rjbarker November 21, 2008 11:23 AM

No, no Daeman Tools at all....I find this odd for the following reasons:
1. Worked fine (same game no issues) prior to my re-loading my OS, Drivers etc
2. Works fine in my DVD RW (IDE) Drive

The only thing I did differently after I load my OS is I installed the "latest" nForce Chipset Drivers as apposed to my originals on my MOBO Disc.....I'm stumped, shouldn't need to download n install a "crack" when its a legite copy with correct Key Code entered.
I'm wondering if thier is something I'm missing.....after the installation of the OS, n Drivers

DarKStar November 21, 2008 04:46 PM

Are you running your SATA drive in IDE emulation mode or AHCI ?
Yes this is caused by SecurCRAP - Sometimes when you haev SCSI devices or devices detected and reported as SCSI it can do that - Maybe it's time that the guys behind those protection schemes update their "engines" to detect SATA ROMs as legit and not as drive emulation which install as SCSI emulation drivers - I've never had this problem before because I have IDE DVD-ROM / Writers, but try Y.A.S.U., the latest version, run it and enable it, and try running your game again. Keep in mind that if you attempt to use a cracked EXE you will not be able to play online, and you might even get yourself banned from some servers so be careful.

Can you tell me how is your DVD-ROM drive detected in device manager ?

rjbarker November 21, 2008 04:58 PM

Thanks for taking the time Dark Star,,,,,so you know COD WaW works fine in the same DVD ROM Drive...

Are you running your SATA drive in IDE emulation mode or AHCI ?
Not sure, how do I check this?..sorry.

Can you tell me how is your DVD-ROM drive detected in device manager ?
In Device Manager how do I let you know this...again sorry Dark Star...

Lead and I shall follow !

rjbarker November 21, 2008 05:23 PM

Thought of something else.....my son had installed this same game (same CD Key) on his Laptop and plays Multi Player.....could the fact that he has it installed on his Laptop cause this somehow? Still doesn't explain why it works on my IDE Drive though....

rjbarker November 21, 2008 08:06 PM

Help guys,,this was is driving me......just loaded Crysis on same Drive...all is fine!

JD November 21, 2008 08:16 PM

I don't think you're understanding the previous posts.

SecuROM (that's the proper spelling) is a form of DRM to prevent illegal copies of the game being played. Now you see, all the virtual CD/DVD drive programs (Daemon Tools/Alcohol 120) use SCSI to emulate said DVD drive. It just so happens that your SATA DVD-RW is probably detected as SCSI too as that's just how things are.

So it's probably assuming that your actual DVD drive is an emulated one and thus the DRM is denying you from using that drive to run the game. However since your IDE drive checks out fine with SecuROM, all is well.

Hopefully that clears things up somewhat...

Crysis used different protection I believe, though Crysis Warhead uses the same as COD WaW I think.

All times are GMT -7. The time now is 04:16 AM.