Go Back   Hardware Canucks > NEWS & REVIEWS > Press Releases & Tech News

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 26, 2011, 11:04 AM
FiXT's Avatar
Hall of Fame
 
Join Date: Apr 2008
Location: GVRD
Posts: 3,343

My System Specs

Default AMD Releases Catalyst 11.1 Driver Suite

AMD's first full driver package of the New Year is released, the AMD Catalyst 11.1 WHQL drivers. Not much to say really, two specific game performance improvements, and a good number of bug fixes for all the various operating systems.

Download (Hosted By AMD)

    AMD Catalyst 11.1 Release Notes     AMD Ca... [ Read full article ]
Reply With Quote
  #2 (permalink)  
Old January 26, 2011, 12:08 PM
JD's Avatar
JD JD is online now
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Word of caution...

Doesn't seem to work on my Windows 7 x64 install. Comes up saying some miniport driver is unsigned and cannot run due to that. It also BSOD'd mid-way when I first attempted to install.

Maybe I've ruined my OS now...
Reply With Quote
  #3 (permalink)  
Old January 26, 2011, 12:14 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,589

My System Specs

Default

Time to see if they fixed the eyefinity bug yet on 6870s yet or not...

Update: No problems installing it on Win 7 64bit Professional.

Update2: Still doesnt go into idle mode when running eyefinity

Last edited by Arinoth; January 26, 2011 at 12:29 PM.
Reply With Quote
  #4 (permalink)  
Old January 26, 2011, 12:40 PM
JD's Avatar
JD JD is online now
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Maybe because I'm running SP1

Oh well, 10.12s still installed fine. I'll live with it for now. Not like my old 5870 is getting any fixes at this point.
Reply With Quote
  #5 (permalink)  
Old January 27, 2011, 10:20 AM
bojangles's Avatar
Hall Of Fame
F@H
 
Join Date: Jan 2008
Location: Oakville, ON
Posts: 2,683

My System Specs

Default

Quote:
Originally Posted by JD View Post
Maybe because I'm running SP1

Oh well, 10.12s still installed fine. I'll live with it for now. Not like my old 5870 is getting any fixes at this point.
Wha? How...

You must be running a pre-release RTM build?
Reply With Quote
  #6 (permalink)  
Old January 27, 2011, 07:26 PM
JD's Avatar
JD JD is online now
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Quote:
Originally Posted by bojangles View Post
Wha? How...

You must be running a pre-release RTM build?
Yeah, it's the RTM build, but from non-proper channels ;) But I like testing out new software before everybody else...even if I means I end up having to a bit.

But let's not de-rail the thread now...
Reply With Quote
  #7 (permalink)  
Old January 28, 2011, 05:39 AM
Top Prospect
 
Join Date: Nov 2007
Location: Ontario, Canada
Posts: 57

My System Specs

Default Still not fixed

-Needs Fix
since the 10.12's, i still get this thing where my mouse pointer slows down over the close button (X) on maximized windows. still an issue with the new 11.1's.


-Overclocking
with the 10.12's, when i overclocked my 5770, the idle clocks would only sometimes jump to 400MHz core / 900MHz memory raising my idle temps by 5+ degrees. it hasn't done it with the 11.1's... yet. hopefully that has been fixed since 10.12's.

-Screen Flickering @ Shutdown/Restart
after buying a new monitor couple months ago (ASUS VE247), i was getting BSOD's and screen flickers when shutting down or restarting my computer. i exchanged (plus cash) for a new monitor (Samsung BX2431), and it did the same. i said eff it and bought an HDMI cable cuz i hated the DVI > HDMI adapter cable, and the flickering went away. for the BSOD's i had to expand and replace an atixxx.dll in the system32 folder using command prompt, and that was fixed. my old monitor did not flicker or cause BSOD's (Samsung 2253BW w/DVI)... strange.

To AMD, thank you for forgetting about people with anything but 6800 and 6900 series cards.
Reply With Quote
  #8 (permalink)  
Old January 28, 2011, 05:48 AM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,589

My System Specs

Default

The 6870 got forgotten as well, look at all the complaints about drivers i've had throughout several threads. The 11.1 still dont fix some of the innate issues (crossfire) since their release.
Reply With Quote
  #9 (permalink)  
Old January 28, 2011, 03:15 PM
Delavan's Avatar
Hall Of Fame
 
Join Date: May 2007
Location: Mtl
Posts: 1,149
Default

Quote:
Oh well, 10.12s still installed fine. I'll live with it for now. Not like my old 5870 is getting any fixes at this point.
After installing the driver 11.1, it still shows that 10.12 is the version running...GPU-Z and CCC are saying the same thing... 5870 here also...
__________________
i7 4770K @ 4.5GHz / Corsair H100i / Maximus VI HERO / 8GB Corsair Vengeance Red LP 1.5V 1866 / N560GTX Ti Twin FROZR II OC / Corsair Performance Pro 128GB SSD / Intel 520 120GB SSD / WD Black 640 GB storage

ROG G53SX laptop: i7 2630QM / 12GB DDR3 / GTX560m 2GB / 750GB 7200rpm (14 000 3Dmarks06)
Reply With Quote
  #10 (permalink)  
Old January 28, 2011, 05:04 PM
JD's Avatar
JD JD is online now
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,903

My System Specs

Default

Quote:
Originally Posted by Delavan View Post
After installing the driver 11.1, it still shows that 10.12 is the version running...GPU-Z and CCC are saying the same thing... 5870 here also...
Puzzling. Maybe it's an issue with 5870s then...

Maybe try doing a full uninstall and re-install of 11.1s?
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD Releases Catalyst 10.12a Hotfix for AMD Radeon 6900 Series Support FiXT Press Releases & Tech News 2 December 17, 2010 11:03 AM
AMD Releases 10.12 Catalyst Drivers & Redesigned Catalyst Control Center FiXT Press Releases & Tech News 4 December 14, 2010 06:04 PM
AMD Releases Catalyst 10.11 WHQL Drivers FiXT Press Releases & Tech News 4 November 21, 2010 04:05 PM
AMD Releases Catalyst 10.9 WHQL Driver Suite FiXT Press Releases & Tech News 0 September 15, 2010 11:40 AM
ATI Releases Catalyst 10.7 WHQL Driver Update FiXT Press Releases & Tech News 8 July 28, 2010 12:48 AM