Go Back   Hardware Canucks > NEWS & REVIEWS > Press Releases & Tech News

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old November 18, 2010, 10:33 AM
FiXT's Avatar
Hall of Fame
 
Join Date: Apr 2008
Location: GVRD
Posts: 3,343

My System Specs

Default AMD Releases Catalyst 10.11 WHQL Drivers

Five hotfixes later, AMD has replaced the Catalyst 10.10s, with November's full release of the Catalyst 10.11 WHQL Certified drivers, bundling all of the previous fixes, and including a few new ones.

Download from GAME.AMD.COM

Performance Highlights of the AMD Catalyst 10.11 release include:

Battleforge

    Performance i... [ Read full article ]
Reply With Quote
  #2 (permalink)  
Old November 18, 2010, 12:03 PM
MacJunky's Avatar
Hall Of Fame
F@H
 
Join Date: May 2007
Location: Creston, BC
Posts: 1,718

My System Specs

Default

oh man, I downloaded these last night for some GPU swapping&playing and I did not even notice that they were this month's. :P
hahaha

*Edit
ok, useful post, useful post, lesee here.
They have been working fine so far with a 5750 and 3850.. No issues yet.*shrug* >_>
Reply With Quote
  #3 (permalink)  
Old November 18, 2010, 12:19 PM
SKYMTL's Avatar
HardwareCanuck Review Editor
 
Join Date: Feb 2007
Location: Montreal
Posts: 11,648
Default

Battleforge: No one plays it but many sites benchmark with it

CoP Benchmark: Ditto


Anyone else see a trend here?
__________________
Reply With Quote
  #4 (permalink)  
Old November 18, 2010, 01:08 PM
FiXT's Avatar
Hall of Fame
 
Join Date: Apr 2008
Location: GVRD
Posts: 3,343

My System Specs

Default

Quote:
Originally Posted by SKYMTL View Post
Battleforge: No one plays it but many sites benchmark with it

CoP Benchmark: Ditto


Anyone else see a trend here?

Oh AMD... I noticed the same trend with a lot of their hotfixes. Conveniently all centered around improvements to benchmarking games.
Reply With Quote
  #5 (permalink)  
Old November 21, 2010, 04:05 PM
ultraman7k's Avatar
Allstar
 
Join Date: Oct 2009
Location: Surrey, B.C.
Posts: 527

My System Specs

Default

is anyone experiencing screen flickers while in browsing the internet? I never had this until I updated to 10.11, I can't remember which version I had been using previously (10.5 maybe?) but my browser is driving my insane...also I noticed that my Memory clocks are underclocked to a low 300 mHz, which is a far cry from the 800 mHz it used to be at...

Google didn't yield any results...anyone else experiencing the same?
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD Releases Catalyst 10.9 WHQL Driver Suite FiXT Press Releases & Tech News 0 September 15, 2010 11:40 AM
ATI Releases Catalyst 10.7 WHQL Driver Update FiXT Press Releases & Tech News 8 July 28, 2010 12:48 AM
ATI Releases 9.11 WHQL Catalyst Drivers FiXT Press Releases & Tech News 3 November 18, 2009 06:00 PM
ATI Catalyst 9.10 WHQL Drivers Released FiXT Press Releases & Tech News 14 October 23, 2009 06:30 AM
ATI Catalyst 9.7 WHQL Drivers Released FiXT Press Releases & Tech News 0 July 23, 2009 11:44 AM