Go Back   Hardware Canucks > HARDWARE > Power Supplies

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old June 3, 2014, 01:46 PM
Top Prospect
 
Join Date: Jan 2012
Posts: 151
Default good budget psu?

A PSU seems to have died on this computer (not mine). Well, the main fan won't spin. Computer starts up eventually though. Eventually, it shuts down. I am thinking it's the psu that is the culprit. Thoughts? :)

It's an old generic PSU and I'm not sure how old (how many yrs). It's not 80 anything.

Is there any moderately priced ones that would be a good replacement? I'm saying that because I'm not 100% sure the PSU is the only problem but I'm relatively sure. Also, it's an older system... Sempron CPU. DDR2 RAM etc. I guess any new psu can go into a new system but I am hoping the mobo is okay. I'm looking at a cheap passive gpu, too. HD Radeon 6450 any good? No gaming is done on this computer.

Therefore, 400W is probably sufficient but it can be more. I was wondering if I should look for modular. Doesn't have to be, though, right?
Reply With Quote
  #2 (permalink)  
Old June 3, 2014, 02:42 PM
Hall Of Fame
 
Join Date: Jun 2009
Location: Nova Scotia
Posts: 2,908

My System Specs

Default

Here are a couple quality ones that aren't expensive.

http://www.ncix.com/detail/seasonic-...30144-1374.htm

http://www.ncix.com/detail/antec-bas...62331-1360.htm

EDIT: Sometimes you can get decent ones on sale for $20-25 after MIR if you aren't in a rush, but thats the best I see right now with a quick look.
__________________
Desktop: Antec Three Hundred, Z77-D3H, 3570K undervolt @4.1ghz with Zalman Optima Cooler, Corsair Vengeance 2x4gb@1866mhz, MSI Cyclone GTX 460, Seasonic S12II 500W, WD Black 1TB, Intel 530 120GB
Away from home light Gamer: Acer Aspire 15.6", A8-3500m undervolt and OC to 2Ghz, 2x4gb Corsair Vengeance, Crucial M500 240gb

Last edited by Bond007; June 3, 2014 at 02:56 PM.
Reply With Quote
  #3 (permalink)  
Old June 3, 2014, 04:56 PM
TTC TTC is offline
Top Prospect
 
Join Date: Mar 2014
Posts: 57
Default

Where are you located? Maybe you can borrow one
Reply With Quote
  #4 (permalink)  
Old June 3, 2014, 05:12 PM
Rookie
 
Join Date: May 2014
Posts: 34
Default

Disconnect it and don't use it. If its a generic POS, its probably dead. Don't kill the mobo, by using bad power. Then you'll need a new system. If your good with a multi-meter and now how to short out a psu to run?.....still won't be under load. Probably pushing 10 volts. Throw it out.

Could also be a failing cap on the mobo, but since the fan isn't spinning on the PSU? Probably a failed cap on the PSU. (Got To Hot)

Last edited by Calypso; June 3, 2014 at 05:17 PM.
Reply With Quote
  #5 (permalink)  
Old June 10, 2014, 07:21 AM
Top Prospect
 
Join Date: Jan 2011
Location: GTA
Posts: 160
Default

Everyone seems to like the Corsair CX430 which runs about $50 but can be had with fairly regular MIRs for about $30 (taxes not included).

If you're really going budget or need something in a rush I think I have a few Enermax NANX 450W I got for $35 a pop that I used to use for cheap PC builds.
Reply With Quote
  #6 (permalink)  
Old June 17, 2014, 04:42 PM
Rookie
 
Join Date: Mar 2013
Posts: 3
Default

I second the CX430, run one in my HTPC and its been great!
Reply With Quote
  #7 (permalink)  
Old June 29, 2014, 05:57 AM
Hall Of Fame
F@H
 
Join Date: Apr 2011
Location: Montreal
Posts: 1,514

My System Specs

Default

I am running an Antec Earth Watts Green 380 for years now without issue. Actually it was able to drive a system with a GTX460 and a Phenom II X4.
__________________
Reply With Quote
  #8 (permalink)  
Old June 30, 2014, 12:25 PM
Top Prospect
 
Join Date: Jan 2012
Posts: 151
Default

Quote:
Originally Posted by Calypso View Post
Disconnect it and don't use it. If its a generic POS, its probably dead. Don't kill the mobo, by using bad power. Then you'll need a new system. If your good with a multi-meter and now how to short out a psu to run?.....still won't be under load. Probably pushing 10 volts. Throw it out.

Could also be a failing cap on the mobo, but since the fan isn't spinning on the PSU? Probably a failed cap on the PSU. (Got To Hot)
I hope it's the psu. Was troubleshooting two systems with similar specs/gen. hardware (both AM2/AM2+) and one Antec 350W and one Seasonic 400W (Tornado) - both have quit around the same time and had similar symptoms. Both are 20-pin so they're old. Hope, I didn't wreck anything else. :) I think both power supplies are done like dinner - probably should have bit the lip and bought a new psu to test?

If either or both systems are still okay minus a defective psu each, then I'll probably re-visit the thread and see what is out there at that time.
Reply With Quote
  #9 (permalink)  
Old July 5, 2014, 08:49 PM
Rookie
 
Join Date: Jul 2014
Posts: 15
Default

A Corsair CX430 would be good to replace that one. Don't buy another cheap POS.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whats a good budget SSD Drive? Blu Storage 12 December 15, 2010 11:05 PM
A good budget bang-for-your-buck card? andynerd Video Cards 24 December 5, 2010 03:11 PM
Intel Destop PC CPU price cuts! Good news for new budget builders :) Silvgearx Press Releases & Tech News 13 April 3, 2009 06:04 AM
ATi to launch RV790? Good news for budget gamers. Silvgearx Press Releases & Tech News 20 December 4, 2008 04:02 PM