Go Back   Hardware Canucks > HARDWARE > Peripherals

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 28, 2009, 10:17 PM
r0bc's Avatar
Allstar
 
Join Date: Apr 2009
Location: AB
Posts: 688

My System Specs

Default Logitech G19 crashes computer

I got a Logitech G19 for Christmas, I'm using Windows 7 64-Bit on a new computer with a clean install and when I install the software and reboot, my computer crashes every time. I've uninstalled and reinstalled the driver software and the same thing happens. If I plug in a old keyboard everything's fine. I've contacted Logitech support but no reply yet, anyone else have the same problems? I'm using the newest driver. Not impressed at all.
__________________

Reply With Quote
  #2 (permalink)  
Old December 29, 2009, 12:21 AM
odis172's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Ottawa, ON
Posts: 682

My System Specs

Default

Driver may be the issue, though it could be that the device is defective. Try it on another computer
__________________
Laptop: Lenovo T420 - Core i5 2520 - 8GB DDR3
Server: 2 xeon E5530 - Asus Z8N-D6 - 12GB DDR3 - 8x 500GB raid 50 - Perc 6/i - Compucase RA448A00
Reply With Quote
  #3 (permalink)  
Old December 29, 2009, 10:47 AM
MVP
F@H
 
Join Date: Jan 2009
Posts: 276
Default

I have the same setup (g19 + W764) and it works for me. Sounds like a hardware issue.
Reply With Quote
  #4 (permalink)  
Old December 29, 2009, 05:49 PM
r0bc's Avatar
Allstar
 
Join Date: Apr 2009
Location: AB
Posts: 688

My System Specs

Default

They sent me another driver to try, I'll check it out later. Not in the mood to see my computer crash right now.
Seems alot of people are having the same problem but works great for others. Its weird.
__________________

Reply With Quote
  #5 (permalink)  
Old December 29, 2009, 08:26 PM
r0bc's Avatar
Allstar
 
Join Date: Apr 2009
Location: AB
Posts: 688

My System Specs

Default

It didn't effing work.
Keepsix are you using a X58?
__________________

Reply With Quote
  #6 (permalink)  
Old December 30, 2009, 05:00 PM
r0bc's Avatar
Allstar
 
Join Date: Apr 2009
Location: AB
Posts: 688

My System Specs

Default

It appears to be working when its plugged into the front panel but it crashes when its plugged into the ports on the motherboard.
__________________

Reply With Quote
  #7 (permalink)  
Old December 30, 2009, 06:06 PM
encorp's Avatar
Hall Of Fame
F@H
 
Join Date: Apr 2008
Location: Toronto
Posts: 3,425

My System Specs

Default

I'll forward this on to logitech and see what I get back from the internal tech department. Might take awhile, my contact is on vacation for a few more weeks. :)
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech G19 Gaming Keyboard Review FiXT Peripherals 1 December 4, 2009 12:57 PM
[WTB] Logitech keyboard (G19 preferred) whsper Buy/Sell & Trade 1 October 20, 2009 12:48 PM
[FS] Logitech G19 full retail $110+ shipping b1lk1 Buy/Sell & Trade 6 September 12, 2009 09:51 PM
Logitech G19 Mini Review Toronto122 Member Reviews 35 August 2, 2009 03:04 PM
New computer, new crashes Asspigeon Troubleshooting 48 October 14, 2007 05:48 PM