Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Overclocking, Tweaking and Benchmarking

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old April 3, 2013, 07:46 PM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default Overclocking with Biostar TZ77XE4

I am using a 2500k with this board. Its a beauty of a board and I love it but I am not sure of the best route for overclocking my 2500k.

Anyone out there have any experience overclocking with this board?

If I set a Fixed voltage for the cpu does that mean it stays at the voltage constantly? I have done this already with 1.3v @ 4ghz and it doesn't seem to change in my monitoring software (HWINFO64). When my processor clocks down it stays at 1.3v. Is this normal? Temps are fine either way.
When I had this chip in my z68 board I was able to OC it to 4.8 with 1.38v with nice low temps. Before I attempt to tackle an OC at that lvl with this board I want to be sure I am doing it right. There don't seem to be any guides out there that I can see.

As usual the help is appreciated.
Reply With Quote
  #2 (permalink)  
Old April 5, 2013, 11:18 AM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default

No one has any advice?
I found my old gigabyte board to be much easier to OC and much for straightforward in bios settings. The bios on this board is a lot more complicated than I'm used to.

I'm running 4.5ghz now at 1.3v. Temps are fine for normal and gaming use but when I run prime they hit 80'c after a few mins. On my gigabyte board I was able to lower PLL and that helped control the temps a bit but on this board all I have for PLL is Enable or Disable something or other with no way to adjust it that I can see.

I am a complete noob when it comes to Z77.
Reply With Quote
  #3 (permalink)  
Old April 5, 2013, 12:53 PM
Rookie
 
Join Date: Oct 2008
Posts: 33
Default

Your Z68 overclocking experience transfers over to Z77 directly. Only major differences I can think of is the naming of features that change between manufacturers. You might have to do some digging to sort that out.
Reply With Quote
  #4 (permalink)  
Old April 5, 2013, 01:33 PM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default

The biostar bios is much more complicated than the blue screen bios I am used to from my Z68 board. That board was very simple to OC. This one is over my head. The settings seem like there is much more tweaking that can be done on this board over my other board.
So far I have it nice and stable at 4.5ghz at 1.3v. LLC is disabled but my temps are high in Prime otherwise fine in gaming. My other board at 4.7ghz at 1.37v maxed out around 75'c in prime. This one is hitting 80'c at 4.5 at 1.3v. Same cooler. On my other board lowering the pll value helped a lot with the temps but I can't find that setting in my biostar bios. Is there a different term for the value in z77 boards?
Reply With Quote
  #5 (permalink)  
Old April 6, 2013, 02:20 AM
MVP
 
Join Date: Jan 2008
Location: Cambridge, ON.
Posts: 499
Default

Whats your CPU cooler brand, its arrangement in case?
Blowing up to top or out back?
Is it seated properly?
Case air flow?
Number Fans bringing air in and out
Restrictive stamped case grille on rear?
__________________
Cambridge,ON
MSI Z77 M Power/Bios17.13b1
3770K@4.5ghz
Mushkin #997007
Noctua NH-D14
Gigabyte GTX 660
Seasonic X-660
Corsair 540 Cube
Noctua case fans
Intel Speed Demon x 2

using Prime 95 27.9


Reply With Quote
  #6 (permalink)  
Old April 6, 2013, 04:09 AM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default

Oh no worries there. Cooling isn't an issue. I have an EVGA Superclock cooler. Its up there with the D14 for cooling performance. I have 6x120mm fans in the case and 1x120mm on the cooler. All but the top 2 fans are intakes.
I was able to drop voltage a down to 1.28v and that tops out at 76'c. I don't think I'll be able to drop the voltage much more than that and still be stable but 1.28 ran overnight just fine with prime. I'll give 1.26v a try this evening and see how if that will stick but I don;'t think it will be enough juice.
Reply With Quote
  #7 (permalink)  
Old April 6, 2013, 04:12 AM
MVP
 
Join Date: Jan 2008
Location: Cambridge, ON.
Posts: 499
Default

Then there is really no issue at all
BTW if you have WHEA errors>processor based
Then its not stable OC.
__________________
Cambridge,ON
MSI Z77 M Power/Bios17.13b1
3770K@4.5ghz
Mushkin #997007
Noctua NH-D14
Gigabyte GTX 660
Seasonic X-660
Corsair 540 Cube
Noctua case fans
Intel Speed Demon x 2

using Prime 95 27.9


Reply With Quote
  #8 (permalink)  
Old April 6, 2013, 04:19 AM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default

So I guess I am oc'ing on this board correctly then? I am still confused to as why the voltage stays at the fixed value I set even when the processor clocks down when idle. Where is the unused juice going? Temps when idle are around 25'C so I'm not worried but I'd like to understand where the unused voltage is going.
Reply With Quote
  #9 (permalink)  
Old April 6, 2013, 07:06 AM
MVP
 
Join Date: Jan 2008
Location: Cambridge, ON.
Posts: 499
Default

Read your manual
I don't use that board BUT you have a specified voltage set for CPU not auto voltage or offset voltage configuration, correct?

This is your board settings available for CPU volts?:
From the manual I believe if I got right one



CPU VCore Mode

This item sets the mode of CPU over voltage.

Options: SPEC Voltage (Default) / Auto / Offset Mode / Fixed Mode

CPU VCore Offset

This item sets CPU Vcore Offset Voltage.
__________________
Cambridge,ON
MSI Z77 M Power/Bios17.13b1
3770K@4.5ghz
Mushkin #997007
Noctua NH-D14
Gigabyte GTX 660
Seasonic X-660
Corsair 540 Cube
Noctua case fans
Intel Speed Demon x 2

using Prime 95 27.9



Last edited by tyreman; April 6, 2013 at 07:20 AM.
Reply With Quote
  #10 (permalink)  
Old April 6, 2013, 07:13 AM
MVP
 
Join Date: Jul 2012
Location: St. John's, Newfoundland
Posts: 417
Default

Manual? Whats that? lol.
Yeah, Fixed Voltage. I previously used offset on my gigabyte board as that was the only option although the same offset setting I used before doesn't want to play nice on this board.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recommendations for Cooler for Biostar tz77xe4? igot6strings Air Cooling 3 March 17, 2013 08:32 AM
Test for BIOSTAR TZ77XE4 loading with Core i7-3770K overclocking 4.8G windwithme CPU's and Motherboards 3 June 1, 2012 10:58 PM
Affordable choice for Intel advanced X79 - BIOSTAR TPower X79 overclocking test windwithme CPU's and Motherboards 4 March 13, 2012 09:47 AM
e8400 + biostar i45 help miggs78 Overclocking, Tweaking and Benchmarking 26 November 3, 2008 04:48 PM
BioStar BIO-Life enaberif CPU's and Motherboards 14 October 15, 2008 10:34 PM