Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 18, 2012, 06:07 AM
botat29's Avatar
Allstar
 
Join Date: Oct 2010
Location: Montreal
Posts: 828
Default F*??%&& Windows 8 , mouse problem

I reboot my Windows 8 PC and my mouse don't work anymore, I don't know what stupid update whit Windows 8 did, the mouse work fine in the EUFI Bios, so it's really Windows 8 problem, changing the port do nothing.


Update ...it's all my USB port I lost.... WTF Microsoft.....

Last edited by botat29; October 18, 2012 at 06:12 AM.
Reply With Quote
  #2 (permalink)  
Old October 18, 2012, 06:41 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,575
Default

Quote:
Originally Posted by botat29 View Post
I reboot my Windows 8 PC and my mouse don't work anymore, I don't know what stupid update whit Windows 8 did, the mouse work fine in the EUFI Bios, so it's really Windows 8 problem, changing the port do nothing.


Update ...it's all my USB port I lost.... WTF Microsoft.....
You seriously want to bitch to Microsoft for running a unstable OS? I think you need to check your head.
Reply With Quote
  #3 (permalink)  
Old October 18, 2012, 06:50 AM
botat29's Avatar
Allstar
 
Join Date: Oct 2010
Location: Montreal
Posts: 828
Default

I fix temporary the problem, I disable legacy USB in the Bios, my printers, usb stick and mouse work now.... will check later when I'm more in the mood
Reply With Quote
  #4 (permalink)  
Old October 18, 2012, 06:58 AM
Bloodystumps's Avatar
Top Prospect
 
Join Date: Feb 2011
Location: Uxbridge
Posts: 229

My System Specs

Default

You are not suppose to use a mouse with Win 8 its for touch screens , why you still using a mouse that is so win 3.1
Reply With Quote
  #5 (permalink)  
Old October 18, 2012, 08:54 AM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 3,306

My System Specs

Default

I do find it strange I would maybe reset the Bios or just shut down the PC unplug the the PSU and push the power butting to drain any electricity in the system then plug every thing back in and try it I think that it might be more of a hard ware problem then a software problem.
Reply With Quote
  #6 (permalink)  
Old October 18, 2012, 09:08 AM
botat29's Avatar
Allstar
 
Join Date: Oct 2010
Location: Montreal
Posts: 828
Default

Quote:
Originally Posted by Shadowmeph View Post
I do find it strange I would maybe reset the Bios or just shut down the PC unplug the the PSU and push the power butting to drain any electricity in the system then plug every thing back in and try it I think that it might be more of a hard ware problem then a software problem.
With Asus we never know....... but as I said the USB port work in the BIOS as the mouse work in the EUFI Bios.
Reply With Quote
  #7 (permalink)  
Old October 18, 2012, 11:21 AM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,412

My System Specs

Default

Did you try re-installing the motherboard drivers?

Do they (the usb ports/hubs) show up in device manager? If they do and you haven't already tried, remove them from device manager and let windows try to pick them up again.
__________________
MSI Z87I Gaming AC / i5 4670K / 2X 4G Gskill 1866 DDR3 / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / random 160G Sata HDD
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 320G Seagate Momentus / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #8 (permalink)  
Old October 18, 2012, 11:37 AM
botat29's Avatar
Allstar
 
Join Date: Oct 2010
Location: Montreal
Posts: 828
Default

thanks Wilson, but it work now, I just disable legacy USB in the BIOS.
Reply With Quote
  #9 (permalink)  
Old December 16, 2012, 04:44 AM
Trial Member
 
Join Date: Dec 2012
Posts: 1
Default

Quote:
Originally Posted by Bloodystumps View Post
You are not suppose to use a mouse with Win 8 its for touch screens , why you still using a mouse that is so win 3.1
Nice Idea...However Windows 8 is being shipped on non-touchscreen PCs. so what is your answer

to those people? Once again I think Microsoft has lost site of the fact the some people actually need to use computer.
Reply With Quote
  #10 (permalink)  
Old December 16, 2012, 05:36 AM
botat29's Avatar
Allstar
 
Join Date: Oct 2010
Location: Montreal
Posts: 828
Default

You revive and old tread just to say that. As I'm the starter I was expecting a solution to this problem, better we close the tread
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard drive problem or Windows 7 Problem?! aeminence New Builds 4 October 13, 2011 06:46 AM
USB Mouse problem apvm Troubleshooting 3 October 28, 2009 08:59 AM
Annoying mouse problem Maplicito Troubleshooting 8 October 26, 2009 03:51 AM
Windows XP Problem... somecanadianguy O/S's, Drivers & General Software 4 August 23, 2009 11:09 AM
Choppy sound/freezing mouse problem Maplicito Troubleshooting 25 February 15, 2009 12:47 PM