Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Helping Hand? Vista Service Pack 1 vs. Your Phenom (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/5634-helping-hand-vista-service-pack-1-vs-your-phenom.html)

FiXT April 17, 2008 03:45 PM

Helping Hand? Vista Service Pack 1 vs. Your Phenom
 
1 Attachment(s)
Starting with the scandalous pulling of the AMD Phenom 9700 from store shelves and the delay of the 9600 and 9500 series CPU, AMD has taken nothing but flak for the TLB errata in its B2 stepping Quad core processors, found in both the Phenom desktop and Opteron server lines. Completely squashing any hopes of a successful launch for the companies first ever Quad CPU , AMD was quick to release a fix to its customers “The Translation Lookaside Buffer (TLB) errata is an L3 protocol issue causing a system hang when running certain client workload applications independent of platform. AMD is immediately introducing an updated BIOS which will correct the TLB errata”(Statement released Nov 18th 2007); partners received updated code for motherboard BIOS’s and the launch went ahead.

However, it was soon discovered that the TLB bandaid had a severe impact on system performance. Users noticed performance losses upwards of 30% in certain applications. As a side note, the TLB “bug”, when not properly patched, runs the chance of causing the system to hang or reset when a combination of certain functions or stressors on the CPU is met. It is not a guaranteed failure, but chances are greatly increased when running above certain clock speeds and all cores fully loaded. While this may pose as a mere nuisance for desktop users, for companies running multiple CPU’s in a server environment, exploiting this bug had the potential to be disastrous. So options were limited - enable the fix and take a hit in performance, or disable and run the risk of crashing at the most inopportune time; either way, at least you had the option.

There are two primary ways of which to go about disabling the fix. The first and most common being through the motherboard’s BIOS. Manufacturers generally include an enable or disable feature, commonly found in the hidden options menu of the BIOS. The second is using “AMD OverDrive”, a program provided by AMD to allow users to overclock and monitor their CPU’s from within an OS environment. This includes a “green light” feature. When the TLB patch/fix is enabled the light shows green. In order to disable it (if not done through the BIOS) one merely has to click the light until it shows as green, encircled by a yellow ring. There is also a red ring function, but it is said this status, while disabling the patch, also completely does away with power saving features and forces increased performance; this in turn equates to higher power consumption and higher temperatures. Between these two options, most consumers were able to easily choose the patch state.


March 18, 2008, heralded the coming of the toted savoir of Microsoft’s Windows Vista. Service Pack 1 was expected to fulfill everyone’s gripes and laments about the perceived “failing” operating system. While it didn’t completely fulfill its expected role, SP1 did include many performance improvements as well as more basic drivers and, for the most part, was a well received patch.

Fast forward a couple weeks, AMD users applying the patch have noticed severe slow downs in their systems. For a patch that was intended to improve performance – this sure isn’t doing it, in fact it has almost made it worse. One person in particular (yours truly) had tried virtually every method possible after installing Windows Vista Ultimate X64 with slipstreamed SP1 update to get the system to achieve gaming frame rates above an aging Intel E4300 with a single ATI 3870 video card. As a note, the system in question is a fresh build
  • AMD Phenom 9600BE,
  • Asus M3A32-MVP Deluxe,
  • 4GB of Ram
  • ATI Radeon 3870 512MB in Crossfire.
Hours of scouring the empty space of the internet revealed nothing. Tips, tricks and tweaks are all applied: manually setting timings and voltages for every option in the BIOS, forcing PCI-E slots to 16X speed, testing with two alternate 790FX motherboards, different ATI and nVidia based graphics card, numerous reinstalls, driver rollbacks, the works.


After the 16th reworking of Google keywords, by fluke I happened upon a discussion between AMD enthusiast who had deduced a rather startling fact – Microsoft, in their infinite wisdom and without informing users, had chosen with Vista SP1, to arbitrarily over ride user’s BIOS settings in regards to the TLB fix. Manually disabled or not, SP1 WILL set the TLB fix to enabled on your system dramatically hurting performance. This is also true of the AOD (AMD OverDrive) utility, even when set to disabled (yellow ring), the TLB fix setting is forced to enabled by SP1 code.

This was quickly confirmed by getting my hands on an original Windows Vista Ultimate CD and reinstalling from scratch. Both shocked and relieved, I found that scores and frames were completely on par with what was expected and re-enabling the TLB Patch in the bios showed scores in conjunction with what was being seen with SP1.

Now that the problem had been revealed, the question was; how to solve it? Fortunately as the forum discussion progressed a solution was found that had worked for a few members. The rescuer was “Sam2008” of “The Rebels Haven” who had earlier developed a program that worked jointly with CrystalCPUID, a popular system CPU utility which shows processor information, in order to quickly and easily disable the TLB Fix for those who were not given a BIOS option to do so. This fix also functioned with Vista’s SP1 and as luck would have it has been the only method I have found which has the ability to override the override. A quick 20 second launch, benchmarks and games soared. While admittedly it is an annoyance, having to launch the program at startup every time (it does not permanently fix the code), a small addition of the program to your automatic system startup routine resolves the grievance and makes the disabling virtually seamless. Now the question remains as to why? Conspiracies have been thrown around about the close relationship between Microsoft and Intel out to destroy AMD in their currently wavering state. However, the more logical explanation may be that perhaps Microsoft was concerned about the lockups and hang-ups being blamed on faulty code within it’s OS rather than the true source – AMD and chose to proactively eliminate the chance for any potential problems. However it seems to have been done in a very hush manner without Microsoft or AMD informing end users about the move and thus leading to some very frustrated users. It has also been rumored that the upcoming release of Windows XP Service Pack 3 may also have this lock embedded, but this has been neither confirmed nor denied, still however, one may want to be a little wary.


BEFORE: Windows Vista SP1 w/ TLB Patch Locked (disabled in BIOS) (3DMark06 v1.1.0)
http://images.hardwarecanucks.com/im...ed(3DMARK).jpg


AFTER: Windows Vista SP1 w/ TLB fix disabled via TLB_Disable Application(3DMark06 v1.1.0)

http://images.hardwarecanucks.com/im...ed(3DMARK).jpg



WinRar 3.71 SP1 w/ TLB disabled by Application
http://images.hardwarecanucks.com/im...BDisabled).jpg


Crysis 1.2.1

http://images.hardwarecanucks.com/im...TLB/Crysis.jpg


With full credit to Sam2008 the following instructions are how to dig yourself out of the mire.
Programs to download:
TLB_ver_1.05.rar (Nice GUI Interface Version)
Crystal CPUID (http://crystalmark.info/software/CrystalCPUID/index-e.html)

**Be sure to download the 32bit version of CrystalCPUID.
  • Extract CrystalCPUID to a folder on the desktop or somewhere easily accessible
  • Extract TLB Disable Tool into the same folder a CCPUID
  • Launch “TLB_Disable.exe” in Administrator Mode
The tool should display this message if properly applied.
http://images.hardwarecanucks.com/im...TLBDisable.JPG

Setup Program AutoRun at Startup:
Setting this program to run at startup is relatively simple. First ensure the program
runs from the directory on the desktop or other location. Once it has been
confirmed start Task Scheduler to setup the auto run. This can be found: Control
Panel > Administrative Options > Task Scheduler. Follow the steps in the screenshots below.




megakoresh July 11, 2010 09:09 AM

Well, I have same problems in some game (most in Dragon age origins) but I have triple core CPU what do I do? I am new to this so any help is appreciated!

sswilson July 11, 2010 09:14 AM

Quote:

Originally Posted by megakoresh (Post 401898)
Well, I have same problems in some game (most in Dragon age origins) but I have triple core CPU what do I do? I am new to this so any help is appreciated!

Wouldn't be related to this at all. Best bet is to start a new thread in the troubleshooting area with a good description of the problem you're having and a breakdown of your hardware / operating system.

megakoresh September 19, 2010 11:00 PM

Well, sorry for late reply, but it worked perfectly, I don't know what would I have done without this threat! Thank you!

Known December 22, 2011 11:51 AM

I just registered here to say this worked amazingly. I have never had any "fix" work as well as this. Thanks so much!

Blackprayer February 8, 2014 09:48 PM

Has there been a fix for this in windows 8, I had to upgrade to 8 and and am now suffering if I try and play any games, any help is appreciated.

Shadowarez February 10, 2014 01:49 AM

If you still have a Triple Core cpu in 2014 and installed win8 then its time to consider upgrading hardware. Even a $400 prebuilt with integrated graphics will be a upgrade at this point.

MARSTG April 6, 2014 03:36 AM

Quote:

Originally Posted by Blackprayer (Post 756113)
I had to upgrade to 8 and

WHY? :doh: Windows 7 works amazingly with older games, I am playing NFSHP2 which is a 2002 game and also NFS Carbon which is a 2006 title. My win7 is even a 64bit edition and i have none of the issues i had with vista 64 bit.

Bond007 April 6, 2014 04:38 AM

I had no issues on 64 bit win 7 with my old triple core either...had some in xp though.


All times are GMT -7. The time now is 03:44 PM.