Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 12, 2012, 01:23 AM
Top Prospect
 
Join Date: Aug 2011
Posts: 71
Default Weird issue installing windows 7. Asking for IDE drivers.

Hello. Im trying to reinstall Windows 7 with a disk Ive used to do just that three times so far without any issue, last time this very weekend.

Windows manages to unpack all its files through the DVDrom but amusingly it then tells me it cant proceed further for lack of a DVD driver The irony is pushed to overdrive by a message saying its fine to put in a different disk now in my DVD to install these mysterious drivers.

The only thing that changed about my computer is that I took out two old HDDs and put in a new one. My DVD drive is a SATA LG Super Multi and its connected to a SATA port as a master device (was slave but changed it hoping it would clear this, no luck). I tried disabling RAID mode in the bios, still the same deal.

Googling suggested a bad windows disk which I think I can safely rule out, and also the possibility of Windows 7 basically needing IDE drivers even though its SATA drivers are fine. Im puzzled as to why this is now an issue while the same system installed fine previously, but what the hell. I can mount my smartphone to give Windows what it wants and have a working box next to it so I guess Im not in too much of a bind but:

1. Can I fix this with the BIOS somehow / convince Windows to grow a brain? ( Board is a Gigabyte Z68X-UD3H-B3. I have four other SATA devices plugged in right now; three HDDs and 1 SSD. I use it as smart cache so its RAID in the BIOS. )

2. Failing that, uhm, I have to admit I have no idea what driver to feed the damn beast. I dont happen to know much anymore about DVD drivers, I've kind of taken system install drivers for granted this last decade, and I was perfectly fine with that :p

Thanks for any help I really appreciate it :)

edit; another detail, my DVDrom seems effectively dead while on this prompt. I cant open it to put in another disk, even though its obviously fine. Windows's belief in a lack of drivers seems to be a self-fulfilling prophecy heh.

edit: just downloaded an Windows 7 image that includes Sp1 thinking id set aside all doubts about my copy and could use my key with it if it worked, but as I feared, I get the exact same problem. Im probably doing something wrong but I dont see what. Everythings SATA, all the hardware is recent and in great shape... Im puzzled. Appreciate any advice.

Last edited by Valamyr; January 12, 2012 at 03:27 AM.
Reply With Quote
  #2 (permalink)  
Old January 12, 2012, 03:57 AM
Top Prospect
 
Join Date: Aug 2011
Posts: 71
Default

Wow I'm lame. This is what you get for staying up all night, you waste 3 hours over nothing

I had tried unsuccessfully to set overall disk management to IDE/RAid and AHCI without success. But there was a little option further in my BIOS to select one of these three modes specifically for a coupling of SATA ports. I set the SATA3 5/6 connectors to AHCI instead of their 'ide' default and bam. Works.

I cant for the life of me say why it wasnt needed before, after all, I swapped dics but I hadnt changed where the optical drive was plugged.... but who the hell cares. It works now :)
Reply With Quote
  #3 (permalink)  
Old January 12, 2012, 09:51 AM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 3,281

My System Specs

Default

hehe I hate it when that happens . which is why I try to force myself to walkaway from the problem for a little while do something else and then comeback.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD 11.6 weird issue JerryZ O/S's, Drivers & General Software 3 July 7, 2011 01:50 PM
Installing ATI drivers in Fedora Varroa O/S's, Drivers & General Software 0 December 10, 2010 06:16 AM
Weird Issue lcdguy Video Cards 12 July 20, 2009 08:52 AM
Trouble installing chipset drivers. Bakerrrr CPU's and Motherboards 5 December 1, 2008 07:34 AM
Weird Vista Issue lcdguy Troubleshooting 19 October 10, 2008 05:17 AM