Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Windows 7 Sleeping NIC (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/45680-windows-7-sleeping-nic.html)

Herne August 16, 2011 08:01 AM

Windows 7 Sleeping NIC
 
Anyone have any idea how to stop the NIC from going to sleep? I have already gone to the Advanced-> "the Allow the computer to turn off this device to save power" and disallowed it but it still happens.

Interesting part is that if I have something running that is generating network activity it doesn't happen. If I am running a torrent client I can VNC into my box at any time.

Keywork August 16, 2011 10:40 AM

I'm actually running into a similar issue with my laptop. Regardless of what options/settings I try, the NIC still goes to sleep and does not awaken properly along with the rest of the laptop. Hopefully someone else here can chime in...

_dangtx_ August 16, 2011 11:06 AM

perhaps install the nic's manufacturer utility so the onboard(nic?) doesn't go on auto? :)

MacGyver August 16, 2011 04:26 PM

Is there a BIOS option that needs to be enabled? Also are you sure the computer is going into S3 state?

Herne August 16, 2011 08:15 PM

Nothing jumped out in the BIOS, and it somehow behaves like O/S activity. Same system, XP never did this anyway. Not positive S3, but 'Put computer to sleep after 30 mins is selected'. I will have to validate behaviour to time when the NIC is sleeping.

JD August 17, 2011 04:12 PM

If you go into Device Manager and open up the properties for the Network Adapter, I believe there's an Advanced tab in there with a bunch of settings? There might be some energy stuff in there perhaps.

Keywork August 17, 2011 04:21 PM

Quick update. Uninstalled whatever NIC driver W7 installed by default, and downloaded and installed the driver package from Intel. I believe this solved my issue....

Herne August 18, 2011 08:19 AM

Quote:

Originally Posted by JD (Post 541802)
If you go into Device Manager and open up the properties for the Network Adapter, I believe there's an Advanced tab in there with a bunch of settings? There might be some energy stuff in there perhaps.

Sadly that is not it. There is a clear Power Management setting that says not to turn it off and yet it does. I *think* the effect of that on my system is that is it is allowed to go into power saving it will, if it is not allowed here then it will only turn off if it sees no activity.

I am going to try to replace the drivers (despite the long-earned fear of removing NIC drivers from Windows)

EDIT: Installed over top and nothing, will try the remove and install tonight.


All times are GMT -7. The time now is 04:02 PM.