Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Steam steam steam... (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/45678-steam-steam-steam.html)

Arinoth August 16, 2011 04:45 AM

Steam steam steam...
 
Well it looks like I'm screwed in getting any of the keys from my steam games off of my own pc as steam will not properly install, uninstall, or delete all the files in that or any other folder i attempt to install steam into. It always fails saying steam.exe cannot be written/edited due to insufficient rights. My profile is the administrator, i'm running it in admin mod, what the hell steam.

The only thing I can think of to attempt to get steam to work on my system again would be to nuke and pave, which i'd much like to avoid as I did a fresh install within the last month or so.

The oh so fantastic part about steam too is you can't see your keys unless you attempt to install the game, unless anyone knows another way around this? Hard to play the first borderlands DLC with my fiancee if neither of us can pull up our keys from steam due to the fact i cant install it on my computer and our connection to steam is intermittent at best. Its looking like I may shift more to D2D and Origin as I can at least look up my damn serial keys on their websites, no need for the desktop browser!

Sagath August 16, 2011 07:26 AM

I've been talking with Arinoth about this issue on WLM this morning.

I've also had this issue occur before, however it wasnt with Steam. After much fist-pounding-on-table research what solved my problem was nothing to do with the program causing the issues...If that makes any sense ;)

The issue is actually caused by MSVC (Microsoft Visual C++ redistributable) in windows, and is usually in conjunction with installing a file via *.msi rather then the traditional *.exe
To rectify it, you can either remove the registries related to MSVC, if you're comfortable with that. Or simply uninstall ALL the different versions (seriously MS, why do I have 4 different redist's in add/remove?) of MSVC and then reinstall whatever was giving you problems.

I'd suggest renaming this to something about "Failure to install: Administration rights" or something, to help out the next guy down the road that runs in to this problem.

Iamcanadian7 August 16, 2011 08:07 AM

AFAIK you can right click a game that uses CD-KEY verification and there will be a view key button. I've used this a few times for games like GTA and BC2. I don't know if all the games have this though.

Arinoth August 16, 2011 08:21 AM

Without the use of steam working?

JD August 16, 2011 02:55 PM

Did you run one of the SSD Tweaker utilities? I think that messes something up. I always have this issue on my laptop but I can't recall what I do to fix it.

Arinoth August 16, 2011 03:33 PM

Nope, never use an SSD Tweaker and it now says it can't delete the old steam file even though its either not there or its the one who puts it there to begin with... no longer admin rights issue

JD August 16, 2011 04:55 PM

Did you try renaming "steam.exe" to "steam1.exe"? Sometimes that helps. Also when you launch it, try right clicking and doing "Run As Admin".

Failing that, try Safe Mode w/ Networking?

chrisk August 16, 2011 05:31 PM

Assuming the solution offered by Sags did not help, have you tried booting in safe mode and deleting the folder then?

Arinoth August 17, 2011 04:33 AM

None of the solutions appear to work, tried this plus half a dozen other things as well and now the only error i get is that steam.exe cannot be deleted as it already exists (no shit, you put it there installer). I've tried with giving added admin rights, by installing to a different folder, removing the regedit file (which then allowed me to completely nuke the folder that had anything left over in it leaving completely empty folders to install to), installing in a completely different directory and I continually now just get that steam cannot be edited or deleted as it already exists error.

Eldonko August 17, 2011 08:22 AM

Why dont you contact Steam support? They should be able to help

https://support.steampowered.com/newticket.php


All times are GMT -7. The time now is 11:16 PM.