Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 30, 2010, 10:25 PM
geokilla's Avatar
Hall Of Fame
F@H
 
Join Date: Aug 2008
Location: Toronto
Posts: 3,622

My System Specs

Default Safely Remove Hardware Can Remove EVERYTHING

Ok this is driving me nuts. My cousin gave me his Compaq Presario CQ45-104TX and it's driving me nuts! Apart from spending $75 to physically clean and fix the hinge, which couldn't be fixed, Safely Remove Hardware is driving me nuts! The Safely Remove Hardware icon is constantly around, saying I can remove the hard drive, the DVD drive, etc. How do I get rid of it?! At first, I thought it was some drivers I installed, like NVIDIA nForce drivers, but this thing has an Intel PM45 chipset. I formatted the laptop and reinstalled Windows 7 Home Premium and even on first boot into desktop, it still says I can remove the hard drive!

I know it doesn't do me any harm, but it's very annoying and I feel that something's gonna break if I don't try and fix it.
__________________
Reply With Quote
  #2 (permalink)  
Old July 30, 2010, 10:30 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,573
Default

Can't do much.. its just how some chipsets roll.

And no it can't break anything.. if a drive or something was in use it'll say sorry.
Reply With Quote
  #3 (permalink)  
Old July 30, 2010, 10:41 PM
Afrodisiac's Avatar
Rookie
 
Join Date: Dec 2009
Location: Montreal, Quebec
Posts: 10

My System Specs

Default

Did you take a look around in Device Manager?
Reply With Quote
  #4 (permalink)  
Old July 31, 2010, 04:33 AM
geokilla's Avatar
Hall Of Fame
F@H
 
Join Date: Aug 2008
Location: Toronto
Posts: 3,622

My System Specs

Default

Quote:
Originally Posted by enaberif View Post
Can't do much.. its just how some chipsets roll.

And no it can't break anything.. if a drive or something was in use it'll say sorry.
Ugh it's so annoying. I thought this was a NVIDIA only thing >.>

Quote:
Originally Posted by Afrodisiac View Post
Did you take a look around in Device Manager?
What am I supposed to be looking for?
__________________
Reply With Quote
  #5 (permalink)  
Old July 31, 2010, 07:38 AM
shaw
Guest
 
Posts: n/a
Default

Are you running the drives in AHCI mode - check the BIOS.
Reply With Quote
  #6 (permalink)  
Old July 31, 2010, 11:14 AM
ipaine's Avatar
Hall Of Fame
F@H
 
Join Date: Apr 2008
Location: Edmonton, AB
Posts: 2,054

My System Specs

Default

Quote:
Originally Posted by shaw View Post
Are you running the drives in AHCI mode - check the BIOS.

That is what will do it. I know in my machine it lists all of the drives ever since I changed it over to AHCI. Oh if you happen to click remove on one that you don't want to then all you have to do is go to device manager and scan for hardware changes. That should get your drive back again.
__________________
"Nothing sucks more than that moment during an argument when you realize you're wrong."


Reply With Quote
  #7 (permalink)  
Old July 31, 2010, 11:19 AM
gingerbee's Avatar
Hall Of Fame
F@H
 
Join Date: Jan 2009
Location: Orillia, Ontario
Posts: 6,824

My System Specs

Default

this has to do with the driver your using. not to sure but have run into this problem many times on hwc's try updating sata/ahci drivers.
__________________
Fav quote "One should strive to achieve; not sit in bitter regret." Ronin Harris
Reply With Quote
  #8 (permalink)  
Old July 31, 2010, 12:09 PM
m1dget's Avatar
Allstar
 
Join Date: Nov 2008
Location: Terrebonne, Qc
Posts: 707

My System Specs

Default

From a non windows user I would simply guess that there's a screwup somewhere in the drivers and every time it syncs the drives it pops you that message to tell you that the buffer is emptied and that you can remove the drive.

But meh... it's windows and manufacturer's drivers are usually only fat broken blob that you can't do crap about it <_<
__________________
"NIX is a classic example of security through obscurity because there is no real monetary reward for crackers and hackers to break Linix" -AkG
Reply With Quote
  #9 (permalink)  
Old July 31, 2010, 03:27 PM
Banned
F@H
 
Join Date: Sep 2009
Location: Montreal, QC
Posts: 5,415

My System Specs

Default

Since the laptop has AHCI enabled, all SATA devices are hot-pluggable, which means that you can connect and disconnect them at will (so long as you safely remove them). This is one of the best features of SATA in my opinion, since it lets you temporarily connect drives to your PC without having to reboot, while still giving you access to the full speed of the SATA bus rather than having to use a USB adapter to get the hot-plugging functionality.
Quote:
Originally Posted by m1dget View Post
From a non windows user I would simply guess that there's a screwup somewhere in the drivers and every time it syncs the drives it pops you that message to tell you that the buffer is emptied and that you can remove the drive.

But meh... it's windows and manufacturer's drivers are usually only fat broken blob that you can't do crap about it <_<
You should do a little more research. Maybe then you would learn that this is how it's actually supposed to work, rather than blaming Microsoft and Windows for perfectly implementing the SATA hot-plugging feature.
Reply With Quote
  #10 (permalink)  
Old July 31, 2010, 03:47 PM
JD's Avatar
JD JD is online now
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,870

My System Specs

Default

As others have said, if you don't want this, which over to IDE/Legacy SATA mode rather than AHCI. Majority of BIOS's should have this option.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Internal HDD show in safely remove hardware... Kilauea Storage 6 July 23, 2010 11:10 AM
help remove virus hohohee Off Topic 16 July 12, 2010 03:29 PM
remove tim stain from cpu? BobbyLou CPU's and Motherboards 6 January 26, 2010 10:51 PM
I can't remove my side panel... Slinger Troubleshooting 5 February 29, 2008 10:26 AM