Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Cat 10.3 'Preview' (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/30004-cat-10-3-preview.html)

Dr_BenD_over March 17, 2010 05:58 PM

Cat 10.3 'Preview'
 
ATI Catalyst 10.3 Preview Driver

:ph34r:

I haven't found anything broken yet...

cozmosland March 17, 2010 06:28 PM

haha i like that,,,, yet...

Ill test it out and report back

IRQ Conflict March 17, 2010 09:40 PM

Played a little Dragon Age. So far so good. I never benched it but with the 9.12 betas I was running with vsync enabled it was at 57FPS which I though odd. It now rests at 60FPS where it should.

I turned off vsync and it runs between 100-120 FPS with full AF and 4xAA (box). 1920x1200. Fram rate seems to be roughly the same inside or out. But DA is not exactly a demanding game.

Syx005 March 18, 2010 01:21 AM

Very nice
 
1 Attachment(s)
Unigine Heaven benchmark up for me 2fps, nice jump from the last set of 10.3 preview drivers. These are definitely staying on my machine.

muse108dc March 18, 2010 04:48 AM

worthwhile trying for the 4890, or is it more 5000 based now?

IRQ Conflict March 18, 2010 05:02 AM

No, apparently there is also a boost for the 4xxx series as well. So they are probably worth checking out.

TopDogZero March 18, 2010 07:34 AM

Thanks for the heads up on these but unfortunately I had one problem.

First off driver installed without problem and I tried a few games with no issues, however later while I was in the off topic section here someone posted a funny youtube video and the moment I clicked on it I got a green screen for the video and a Driver Failed And Was Restarted Error or something to that affect? Tried clicking on the vid again and this time PC locked up, so I restated and just to make sure this was repeatable and not some fluke I tried again with same result.

After rebooting again I uninstalled the driver through ATIís driver install package which has an uninstall function, then reinstalled 10.2 and tried again and to my surprise had the same problem? (Note: rebooted between each step in case someone was wondering)
So finally resorted to driver cleaner and reinstalled 10.2 again and finally got flash video working again.

Now it must be noted Iím running the Beta GPU accelerated version of Flash 10.1 and a recent fresh install of Win7 and I rarely have any problems with ATI drivers so something between the beta version of flash and preview driver? Or something particular with my system.

bojangles March 18, 2010 08:08 AM

I'm looking forward to the release of these. I'd love to see more performance out of my Mobility Radeon 4830.

Digikid March 18, 2010 09:10 AM

Got a 500 point Vantage boost from these....nice. Framerates seem a little smoother as well.

These are keeper drivers for sure.

Dr_BenD_over March 18, 2010 09:27 AM

10.2 vs 10.3 (Preview)

Heaven (Default, windowed)
46.9 vs 52.6 aka 12%+

Vantage

X7097 vs X7341 aka 3.4%+ (6% higher FPS in New Calico)


All times are GMT -7. The time now is 06:26 AM.