Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Error installing Windows 7 (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/29379-error-installing-windows-7-a.html)

Waldie February 28, 2010 09:46 PM

Error installing Windows 7
 
Hey, I'd appreciate advice on a little problem I'm having.

I currently have the Windows 7 RC, 64-bit and trying to install Windows 7 Ultimate. I'm receiving an error saying:

setup.exe - Bad Image
D:\Sources\SPWIZENG.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

This is then immediately followed by a window that says:

The file 'autorun.dll' could not be loaded or is corrupt. Setup cannot continue. Error code is [0xC1]

Now, obviously the first thing I did was run a search, and it turns out that a fair number of people have had this problem, not only with Windows 7 but also Vista, and not only with iso's but with bought dvd's as well. There were a couple people who said that downloading the image again solved their problem, but there were also quite a few that said they downloaded 4-10 times without it changing anything. Other people have also recommended burning the dvd again, slower, but when I mount the image on PowerISO I get the exact same error, so obviously it did not occur as a result of the burning process messing up.

I am currently downloading again, but I'm downloading from TechNet, so I doubt the file is corrupt on their end, and my initial download was not interrupted at all. I hate having to use the 3 GB of bandwidth if that's not the problem, but I don't know what else I could try at this point. I'd like to resolve this tonight if possible, since I have only hours until the RC starts shutting down every two hours.

The only thing that gets me is that this seems to have happened a lot with no clear-cut reason, but it's always this one .dll at fault. It can't just be a random corrupt part of the iso image if it happens for multiple people across multiple OS's over a period of years, and always the same file.

Anybody have any advice for me? I'm currently re-downloading the iso from technet at 1 MB/s, so it'll be ready to test out again in around 45 minutes.

belinik March 1, 2010 01:43 AM

I had a similar issue back then in both vista and 7....... solved it by booting the disc directly instead of running it from windows

Since you mention you got it from technet I assume it is a full version?

wild guess but it has to do with incorrect bit version(32 vs 64). or drivers/partition issue.

Waldie March 1, 2010 08:15 AM

Ok, I solved it... Yeah it was full version. I came across something at the very bottom of the twentieth (approx) page that I looked at about the problem.

Some guy said he was at a complete loss, until it dawned on him what he would do in Microsoft's position. Essentially, force people to use your programs. Basically, for some reason you need the Microsoft file transfer from Internet Explorer in order to download the iso properly, otherwise it's corrupted. I'm guessing this isn't always the case, otherwise everyone who downloads from TechNet using another browser wouldn't be able to use their downloads.

It worked for me though. I had been downloading the iso (twice) with Chrome, originally, and I was getting the error, and then I re-downloaded it with IE (also, much faster, was cooking along at 2 MB/s) and it worked like a charm, with no problems. Seems a little malicious, but obviously not using IE caused the problem.


All times are GMT -7. The time now is 06:26 AM.