Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 2, 2009, 08:08 PM
MVP
F@H
 
Join Date: Jun 2007
Location: Montreal
Posts: 337
Default Problem booting freenas from USB

Hey so I have freenas running pretty much the way I want to but every time I restart I lose my configuration.

I have tried with two thumbdrives and I get the following:

FreeBSD/i386 boot
Default:0:fd(0,a)/boot/kernal/kernal
boot:

anyone have any ideas on whats wrong?

at first I thought it was a setting in the bios but I have played with everything I could think of.

its an Abit IP35-e

Help would be greatly appreciated
Reply With Quote
  #2 (permalink)  
Old December 2, 2009, 09:25 PM
Jack Rabbit's Avatar
Allstar
 
Join Date: Sep 2007
Location: Toronto, ON
Posts: 784

My System Specs

Default

If FreeNAS can not find a writable USB stick or a floppy drive it seems to silently switch to a 'virtual floppy' file system of some sort.

I used physdiskwrite (sp?) to copy the embedded image to my USB stick and it seems to work fine and save settings. How did you get the data on your USB stick?
__________________
He either fears his fate too much, or his deserts are small, that dares not put it to the touch, to gain or lose it all.
- James Graham
Reply With Quote
  #3 (permalink)  
Old December 3, 2009, 09:22 AM
MVP
F@H
 
Join Date: Jun 2007
Location: Montreal
Posts: 337
Default

hm.... i might give that a shot I was running it off the live CD and try embedding onto the usb with and without the swap partition

EDIT just tried physdiskwrite and I can see the usb in the hard disk boot list but i get the disk read error, please insert system disk.

using freenas ISO for the live CD
and i tried the embedded

Last edited by klaiboi; December 3, 2009 at 10:01 AM.
Reply With Quote
  #4 (permalink)  
Old December 4, 2009, 08:30 PM
MVP
F@H
 
Join Date: Jun 2007
Location: Montreal
Posts: 337
Default

up to the top
Reply With Quote
  #5 (permalink)  
Old December 4, 2009, 09:48 PM
Jack Rabbit's Avatar
Allstar
 
Join Date: Sep 2007
Location: Toronto, ON
Posts: 784

My System Specs

Default

My FreeNAS mainboard is an older Asus A7V (IIRC) and for some reason I have to enable 'legacy USB' for it to boot from the USB flash drive. You could try that.

Some USB sticks just will not boot. Have you tried a couple of the other tools for making it bootable with DOS or something just to see if anything will boot?

Also, did you try a couple different USB ports? Mine will not boot from the front panel ports but will from the backplane.
__________________
He either fears his fate too much, or his deserts are small, that dares not put it to the touch, to gain or lose it all.
- James Graham
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help freenas and ASUS o!play klaiboi Networking 0 November 13, 2009 03:27 PM
USB Mouse problem apvm Troubleshooting 3 October 28, 2009 08:59 AM
Booting Problem, Possible Solution? ImmaPC Storage 8 November 27, 2008 07:35 PM
Computer booting problem Hillsdale Storage 8 June 5, 2008 12:53 PM
stacker 830 front usb ports problem... CraigHf Troubleshooting 4 April 13, 2008 07:07 PM