Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   O/S's, Drivers & General Software (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/)
-   -   Problem booting freenas from USB (http://www.hardwarecanucks.com/forum/o-ss-drivers-general-software/26168-problem-booting-freenas-usb.html)

klaiboi December 2, 2009 08:08 PM

Problem booting freenas from USB
 
Hey so I have freenas running pretty much the way I want to but every time I restart I lose my configuration.

I have tried with two thumbdrives and I get the following:

FreeBSD/i386 boot
Default:0:fd(0,a)/boot/kernal/kernal
boot:

anyone have any ideas on whats wrong?

at first I thought it was a setting in the bios but I have played with everything I could think of.

its an Abit IP35-e

Help would be greatly appreciated

Jack Rabbit December 2, 2009 09:25 PM

If FreeNAS can not find a writable USB stick or a floppy drive it seems to silently switch to a 'virtual floppy' file system of some sort.

I used physdiskwrite (sp?) to copy the embedded image to my USB stick and it seems to work fine and save settings. How did you get the data on your USB stick?

klaiboi December 3, 2009 09:22 AM

hm.... i might give that a shot I was running it off the live CD and try embedding onto the usb with and without the swap partition

EDIT just tried physdiskwrite and I can see the usb in the hard disk boot list but i get the disk read error, please insert system disk.

using freenas ISO for the live CD
and i tried the embedded

klaiboi December 4, 2009 08:30 PM

up to the top

Jack Rabbit December 4, 2009 09:48 PM

My FreeNAS mainboard is an older Asus A7V (IIRC) and for some reason I have to enable 'legacy USB' for it to boot from the USB flash drive. You could try that.

Some USB sticks just will not boot. Have you tried a couple of the other tools for making it bootable with DOS or something just to see if anything will boot?

Also, did you try a couple different USB ports? Mine will not boot from the front panel ports but will from the backplane.


All times are GMT -7. The time now is 04:42 PM.