Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 13, 2009, 11:51 PM
Ritz's Avatar
Top Prospect
 
Join Date: Sep 2009
Location: Calgary
Posts: 89

My System Specs

Default New drivers for 5800/5700 series conflicting with sound card?

Hey guys. AMD has released updated drivers for the 5800 and 5700 series. However, I have been experiencing problems. I'm not sure if it's just me or if others might also experience issues. Specifically, when playing Assassin's Creed, the game will freeze, the sound will loop and then things get bad.

I shut down the game, and shut down the machine. When I boot back up, my sound card doesn't want to work. Instead, when I go into the device manager, I see an error that says this about the driver for my soundcard:

"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

And it didn't matter how many times I uninstall and reinstall the sound card driver (shutting down each time), I keep getting that Code 52 error. It was really frustrating. However, I managed to get everything back to a working state, but not before I uninstalled Catalyst and everything else and rolled back to the Sept 21 drivers did I get things back in working order.

Relevant system specs:

Windows 7 Ultimate RTM 64 bit
Intel Core i7 920
Radeon 5850 video card
Auzentech X-Plosion 7.1 Cinema soundcard (DTS Interactive over S/PDIF enabled)

I went into safe mode and uninstalled the soundcard driver. I then booted back into Windows normally and uninstalled the video driver and all of ATI's other software. I then went into Device Manager and made sure that the video driver for the graphics card was gone even there. I rebooted and was welcomed to a nice 640x480 screen. I reinstalled the old drivers from Sept 21 for the video card. Rebooted. Went into Device Manager and disabled the ATI High Definition Audio Device. Downloaded the same driver from Auzentech's site for Windows 7 that I had already tried over and over. Installed that. Rebooted.

Everything works! But I'm still on the old video drivers =(
__________________
I REALLY want a solid state disk drive. Really awfully badly.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD ATI Launch Mid-Range HD 5700 Series Video Cards FiXT Press Releases & Tech News 0 October 13, 2009 12:41 PM
Sapphire Giving Away a 5800 Series Graphics Card Every Day! FiXT Press Releases & Tech News 7 September 30, 2009 04:24 PM
AMD/ATI Releases Hotfixed Drivers for 5800 Series Video Cards FiXT Press Releases & Tech News 7 September 29, 2009 02:11 PM
5800 series release date? BobbyLou Video Cards 27 September 22, 2009 02:46 AM
HP Vectra VL 6, series 8, sound card driver trodas Troubleshooting 0 September 11, 2008 04:22 PM