Go Back   Hardware Canucks > SOFTWARE > O/S's, Drivers & General Software

    
Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old June 19, 2009, 08:44 AM
Waldie's Avatar
Top Prospect
F@H
 
Join Date: Apr 2009
Location: Whitby, Ontario
Posts: 94
Default

Ditto to what everyone else has been saying. I installed Win7 on my new build a month and a half ago, and I love it. Can't find a single thing to complain about, and I haven't had a single thing not work. That includes Diablo II for me, too. Plus it's free for now, up until March next year. Although I know I'm going to forget about that, and I'm going to be annoyed as hell.
__________________
E8400 | EVGA 750i FTW | EVGA GTX 260 Core 216 SC | G.Skill 2x2GB DDR2-1000 | WD 640GB Black | Corsair TX750W | CM 690 | Acer H233H
Reply With Quote
  #22 (permalink)  
Old June 19, 2009, 09:55 AM
artistpavel's Avatar
Allstar
 
Join Date: Feb 2009
Location: Toronto ON
Posts: 580

My System Specs

Default

For some reason, when I enable Aero in Windows 7, FPS drop 20-30% and brushes start to lag in Photoshop. Basic theme works better but windows leave trail when moved, like ghosting.

It's been like that since January beta and now with RC.
Reply With Quote
  #23 (permalink)  
Old June 19, 2009, 01:15 PM
bovine.baron's Avatar
MVP
F@H
 
Join Date: Feb 2009
Location: Vancouver, BC
Posts: 486

My System Specs

Default

It's been working perfectly except for a sudden problem with Fallout 3 crashing that just started this week. I don't know if it's Win7 since it had worked so well before and I haven't done any updates recently, and I don't think it's my set of mods since they've been stable for about a month. Beats me. Works great with every other game though, even older ones like the previous Fallouts and Call of Cthulhu.
Reply With Quote
  #24 (permalink)  
Old June 19, 2009, 01:32 PM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 3,397

My System Specs

Default

Quote:
Originally Posted by bovine.baron View Post
It's been working perfectly except for a sudden problem with Fallout 3 crashing that just started this week. I don't know if it's Win7 since it had worked so well before and I haven't done any updates recently, and I don't think it's my set of mods since they've been stable for about a month. Beats me. Works great with every other game though, even older ones like the previous Fallouts and Call of Cthulhu.
what is crashing the OS or the game? check and make sure that your Drivers are up to dat.

I have to admit that even though win 7 is almost /just at Beta it is a really good OS compaired to vista this OS is really good I have been using it for only about 3 weeks and the only problems I have is with my Xonardx audio card but I am not sure if it is the card or the drivers for the card I just don't use the card right now I use the on board sound. it does use allot of ram just like vista it uses when I am sitting here idle 15% of my 8gb ram but this isn't tweaked at all so I could probably get it down to around 8-10%.
I haven't had any games crash yet mind you I have only been playing D2LOD and KOTOR
Reply With Quote
  #25 (permalink)  
Old June 20, 2009, 08:44 PM
bovine.baron's Avatar
MVP
F@H
 
Join Date: Feb 2009
Location: Vancouver, BC
Posts: 486

My System Specs

Default

Quote:
Originally Posted by Shadowmeph View Post
what is crashing the OS or the game? check and make sure that your Drivers are up to dat.
Yeah, I updated my drivers once I noticed the frequent crashing, but it still went on. It's just the game, by the way. Only time I've had Win7 go out on me was on a bad CPU overclock that was prime stable but FAH wrecked it even then, it went into hibernate instead of shutting off completely so my stuff was still there. Anyway, FO3 has stopped crashing since; I guess it's becasue I was playing Operation: Anchorage and it wasn't playing nicely with my other mods.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: New Gaming Rig kruzn4evr Buy/Sell & Trade 17 October 28, 2009 08:31 PM
XP-64bit or Vista-64bit or Windows 7 beta?- new gaming rig Ruff_Ryda New Builds 13 April 25, 2009 05:54 PM
[FS] Gaming Rig E6300 3.0GHz, 8800 GTS, 2GB OCZ Gold,250GB HD, Windows XP Pro,Antec 300 riflepwnage Buy/Sell & Trade 1 February 18, 2009 11:45 AM
Which Windows OS is best for gaming? CactusJoe New Builds 13 November 29, 2008 10:53 AM
Gaming Rig janes780 Case Mods, Worklog & Gallery 10 January 15, 2008 08:16 PM