Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Networking (http://www.hardwarecanucks.com/forum/networking/)
-   -   Question for the experts... WDTV Wifi (http://www.hardwarecanucks.com/forum/networking/58662-question-experts-wdtv-wifi.html)

KRAFTIG December 22, 2012 12:49 PM

Question for the experts... WDTV Wifi
 
First off please excuse my ignorance on this topic... I currently discovered that I can have my WDTV pickup my share drive on my PC, so instead on moving a portable hard drive back and fourth I can connect through wirless router. Problem is the signal keeps cutting out. I have WRT160N v3 (Linksys/Cisco) router. How can I improve the situation? Is this a simple upgrade of my router for video streaming wireless video? Any help is greatly appreciated.

KaptCrunch December 22, 2012 05:43 PM

whats the model # of your wdtv

enaberif December 22, 2012 05:52 PM

Quote:

Originally Posted by KRAFTIG (Post 679600)
First off please excuse my ignorance on this topic... I currently discovered that I can have my WDTV pickup my share drive on my PC, so instead on moving a portable hard drive back and fourth I can connect through wirless router. Problem is the signal keeps cutting out. I have WRT160N v3 (Linksys/Cisco) router. How can I improve the situation? Is this a simple upgrade of my router for video streaming wireless video? Any help is greatly appreciated.

crappy router. should have bought a asus

DarKStar December 22, 2012 06:43 PM

Are you using the latest firmware ? Make sure your firmware is up to date.

I also had an old WD TV and used WIFI combined with a D-Link router and not a single drop - used it for a long time, until I eventually purchased a Samsung LED LCD with built-in allshare / smart TV, no longer need the WDTV, and far better than the WDTV.

Try accessing your router's wireless status page and check the signal level.

The model I used was a WD TV Live and a WiFi USB adapter (DLink), never an issue.

3.0charlie December 22, 2012 07:06 PM

Quote:

Originally Posted by enaberif (Post 679650)
crappy router. should have bought a asus

Unfortunately, I second that opinion - that WRT160N is one of the worst routers I've ever used.

enaberif December 22, 2012 07:54 PM

Quote:

Originally Posted by 3.0charlie (Post 679668)
Unfortunately, I second that opinion - that WRT160N is one of the worst routers I've ever used.

When Linksys (Cisco) decided to drop the antennas on the routers and went internal the routers turned to utter crap.

The 160N was such a crippled piece of crap as well.

KRAFTIG December 22, 2012 10:55 PM

Quote:

Originally Posted by KaptCrunch (Post 679649)
whats the model # of your wdtv


It is a WDTV Live.

KRAFTIG December 22, 2012 10:57 PM

Quote:

Originally Posted by 3.0charlie (Post 679668)
Unfortunately, I second that opinion - that WRT160N is one of the worst routers I've ever used.

I've had the unit for 2-3 years served its purpose for Wi-Fi for my iPhone.

So the question is do I have to spend $170 on a router to stream HD movies and provide Wi-Fi for my iPhone?

Perineum December 22, 2012 11:10 PM

Chances are the WDTV Live is your issue. I set one up for a client with wired ethernet and it couldn't stream a movie to save it's life. I tried various versions of it's firmware and there was an old one that would drop out and completely stop working maybe once every 4 movies. Any other firmware version caused it to skip like a dirty DVD.

I replaced that hunk of crap with a AIOS Pivos and it's never stopped working since.

I can't imagine that WDTV works any better via wireless than it does wired.

If you suspect your wireless is okay, then it's definitely the WDTV.

MAK December 23, 2012 02:53 AM

I suspect it may be the WDTV too... but I agree with the others who say the router isn't the best. I'd never trust that router - there isn't even a plug for an external antenna. I wonder what the range of the wireless is...

I can't help with the WDTV side of things.. I don't have one of those. But for the router:

The router may have been working great with the iPhone - especially if it was running slow (it may have connected as 802.11g or even 802.11b which is much slower than the new 802.11N). You may not have noticed the slow speed or if the connection hiccups occasionally.

But if you are trying to stream a movie (especially HD) you will need the 802.11N speed, and you want it to be as error free as possible (no dropped connection, then reconnect etc...).

Try some of the following:
1. See if it is the wireless' fault. Get (or borrow) a network cable long enough to go from your router to the WDTV and see if it works any better. (Perineum tried that and it didn't work, you should test it too.) Bear in mind that that router does not have wired Gigabit support (another reason I don't like it) but a wired 100Mb connection should be more than enough for HD.

2. Move the router closer to the WDTV. Maybe its the range you get with the router's internal antenna. It shouldn't be closer than half a meter, though. Try getting the two devices a few meters apart and see if that helps.

3. Check your wireless security. Are you using older encryption like WEP ? (I hope not, but I'd better ask). Some routers will drop down to wireless G speeds if you use WEP...change it to WPA.

4. Change the wireless channel. This happened to a friend of mine (interference from a neighbour) and a simple change of the channel cleared up the air, so to speak.

5. Borrow a newer router from someone (if you can) and test it out. That might solve the problem. If it does, then you might decide to buy another router or try to fix your firmware.

6. (this is very technical and may be irreversible) Try changing the firmware on the router to something like DD-WRT or Tomato. This may solve some problems, maybe even give you better Wireless N performance, but it is a lot less 'user friendly' than the firmware that came with the router. You will end up looking through the online help and wikis if you want to set up and configure your router with one of these open source firmware. I'd recommend you ask around for help on this one, and see if it helped anyone else with the same router model.


Hope this helps a bit.

[edit] I just found the support page for the router (here) and under "dropping/intermittent connectivity" there's one more thing you can try: turn off Upnp (I guess it would be off anyway).


All times are GMT -7. The time now is 05:32 PM.