Go Back   Hardware Canucks > SOFTWARE > Networking

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 4, 2012, 07:03 PM
Rookie
 
Join Date: Jul 2009
Posts: 10
Default TP-Link wr740n

I bought tp-link wr740n wireless router about 10 days ago at ncix. But recently the wireless is acting funny. It will give out IP addresses via dhcp; but after anywhere from 5minutes to an hour no wireless devices that's already connected can access the internet nor the local network. PCs will say it's connected (the bottom right icon still has a globe) but it will not work. Using network diagnostic on windows pc, it says the wireless router is not responding. Disconnecting the pc from the network and reconnecting does not work. It will say "network unavailable" but the network can be seen in the list of wireless networks.

The only way to fix this is to restart the router. I have updated to the latest firmware (3.12.11 I think) and the hardware is ver.4.

I suspect it's a faulty wireless chip. Any suggestions?
Reply With Quote
  #2 (permalink)  
Old July 5, 2012, 06:59 PM
Rookie
 
Join Date: Nov 2010
Posts: 26
Default

does it overheat or anything? that seems to be a common problem for some routers..
Reply With Quote
  #3 (permalink)  
Old July 6, 2012, 12:30 AM
Rookie
 
Join Date: Jul 2009
Posts: 10
Default

No it doesn't seem hot to the touch. I brought it back to NCIX exchanged for a new one and it works perfectly fine.

Thanks for the help though!

EDIT: After testing the replacement for a few days. It has the same problems as the first one. I found another workaround is to disable and re-enable the wireless NIC on the computers and they will connect to the wireless network again.

Last edited by celestialguy; July 7, 2012 at 03:26 PM.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
TP-Link ? botat29 Networking 3 April 4, 2011 04:52 PM
Problems with Telus' D-Link D-link DVA G3810BN - extra router? chartkor Networking 8 January 4, 2011 12:55 AM
I need a link to this. Spikemaul HardwareCanucks F@H Team 3 November 17, 2009 02:14 PM
i7 QPI Link... somecanadianguy Overclocking, Tweaking and Benchmarking 9 May 31, 2009 04:03 PM
perma link help gingerbee Off Topic 0 January 29, 2009 08:21 AM