Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Networking (http://www.hardwarecanucks.com/forum/networking/)
-   -   Running VMware server, trying to access it outside my network. (http://www.hardwarecanucks.com/forum/networking/50395-running-vmware-server-trying-access-outside-my-network.html)

supaflyx3 January 12, 2012 03:17 PM

Running VMware server, trying to access it outside my network.
 
I'm running debian in a VM, I'm trying to SSH in to my server. I've forward port 22 to the IP debian gives me. (192.168.19.128) but accessing it outside my network doesn't work, so i tried forwarding it to my computer IP (192.168.0.100) to see if that made a difference, nope still can't access the server. I have no problem connecting to shell on my own network connecting to 192.168.19.128. Anyone have a suggestion?

dandelioneater January 12, 2012 03:30 PM

Heh. Im working on setting up the same thing. I am using ubuntu 10.10 with openssh setup on it. I can ssh in with any computer on my LAN at home, but haven't yet been able to connect remotely from work. If I get it figured out i'll post back. I'm using puTTy to connect as well as trying it on my ipodtouch with pterm app.

enaberif January 12, 2012 05:00 PM

you have to make sure your vmware network is set as nat iirc

LarkStarr January 12, 2012 06:58 PM

outside your network? you have to access your public IP, not your internal IP.

dandelioneater January 12, 2012 08:31 PM

Quote:

Originally Posted by LarkStarr (Post 589713)
outside your network? you have to access your public IP, not your internal IP.

hmm. It just times out and doesnt connect. ssh port is being forward to the server's lan ip. I even put the server on the DMZ, made sure software firewalls were disabled. still doesn't want to go. argh.

http://i1112.photobucket.com/albums/..._Capture-2.png http://i1112.photobucket.com/albums/...Capture2-1.png


This might be worth reading. port forwarding
and this

supaflyx3 January 12, 2012 10:00 PM

Quote:

Originally Posted by LarkStarr (Post 589713)
outside your network? you have to access your public IP, not your internal IP.

Well i know that, it times out when i connect to my external IP or the domain forwarded to my IP.

Keywork January 13, 2012 08:08 AM

If you have a minute to quickly check, install apache/nginx on your debian VM, create a port forwarding rule for port 80 and try to browse it from the outside. I can guarantee you'll get the same behavior. I think you've butched your port forwarding somewhere along the line. What sort of gateway or router are you using?

Also, I see you guys changed your default SSH ports (good!). Maybe you used 22 somewhere still?

Arinoth January 13, 2012 08:14 AM

This is the reason why I prefer the lazy man way, which is to use the freeware software of Team Viewer and just remotely access/control the device using my phone, external computer from the network (either normally or with the web browser).

JD January 13, 2012 11:55 AM

Your VMware NIC should be set to "Bridged". This will pull an IP directly from your router, and thus you'll be able to port forward it like usual.

By having VMware's NIC on "NAT", you are effectively double-NAT'ing your network, and as such making it impossible to port forward that traffic out/in.

Main goal: get Debian/Ubuntu to get an IP address from your router, likely 192.168.0.xxx. Then in your router, either put that into DMZ or port forward the necessary ports to it. Personally I wouldn't open up SSH on the common ports. Use something unique to prevent script kiddies from hammering it.

enaberif January 13, 2012 11:56 AM

Quote:

Originally Posted by JD (Post 589991)
Your VMware NIC should be set to "Bridged". This will pull an IP directly from your router, and thus you'll be able to port forward it like usual.

By having VMware's NIC on "NAT", you are effectively double-NAT'ing your network, and as such making it impossible to port forward that traffic out/in.

Main goal: get Debian/Ubuntu to get an IP address from your router, likely 192.168.0.xxx. Then in your router, either put that into DMZ or port forward the necessary ports to it. Personally I wouldn't open up SSH on the common ports. Use something unique to prevent script kiddies from hammering it.

Bridged! Right.


All times are GMT -7. The time now is 04:47 PM.