Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Networking (http://www.hardwarecanucks.com/forum/networking/)
-   -   Internet Speed confusion and NAT problems have me in a tizzy. (http://www.hardwarecanucks.com/forum/networking/39806-internet-speed-confusion-nat-problems-have-me-tizzy.html)

Mr. Gruntsworthy January 11, 2011 07:08 PM

Internet Speed confusion and NAT problems have me in a tizzy.
 
Hi, all. I've been having a slew of strange shenanigans with my internet and NAT settings. Lemme provide the set up.

My Internet Service: Rogers Express Hi-Speed Internet. 9 Mbps download/512kbps upload
Location: Oshawa, Ontario
Router: LinkSys Wireless-N Broadband router, WRT160N firmware 3.0


Beforehand, I've always had extremely slow/nonexistent access to the internet while running BitComet or other torrent software; while active, I was always slow to load web pages, and sometimes I was completely blacked out from anything else on my computer accessing the internet while it was running (such as MSN, web browsers, Steam). After closing Bitcomet, my internet would always be slow afterwards, until it seemingly cleared up a day or two later each time.

Then, one day, I notice the notification about my Listen Port in the bottom of Bitcomet; yellowed to say it's blocked. After much f***ing around to figure out what's going on, I determined that the only way to clear the listening port was to reboot my router. (Even restarting my computer wouldn't clear the listening port). Sometimes I can run Bitcomet two or three times before it starts getting blocked, but most often I only need to run it once and the next time I go to open it the listening port is blocked.

Fast forward to a week ago. Getting sick of this frustration, I ran a few tests on speedtest.net. The result averaged out at about 4.5mbps download. (this was after having run bitcomet the day before, and not rebooting my router quite yet).

I phoned in to rogers customer support, and after rebooting my modem and my router, I ran the speedtest again. I found out that SOMEHOW, after rebooting my router and modem, I was getting TWICE the download speed I should be! Let me reiterate; I only pay for 9 megabytes a second download; my speedtest was hitting anywhere from 18mbps to 21mbps every time. Even Roger's own speedtest showed the same result. The rogers guy told me to keep quiet about the speeds... Anyways, after I reboot my router, I somehow enjoy twice my specified download speed until I start up bitcomet, and then I get throttled all the way back down to 4.5mbps, sometimes even 3.5. Whenever I try to play games online after using bitcomet and before rebooting my router, I always lag.

Now, all of a sudden, my Xbox 360 game Halo Reach's built-in NAT detector warned me that my NAT is now set to Moderate, rather than Open like it's always been. Which is strange, since I haven't changed ANY settings in my router, or updated it.

I'm getting fed up with my network's incompetence... I personally think that the moderate NAT settings, the throttled internet, and the blocked listening port in bitcomet are all connected.


So, I turn to you guys in hopes of sorting this stuff out. You did me the favor of reading that wall of text, so the least I can do is organize the questions...



1) Why do I get throttled back to 50% or lower of my paid internet speed during, and after, running Bitcomet? Is it Rogers? Is it my Router?

2) Is there any way to stop the throttle so that I don't have to manually reboot my modem and router every time I run Bitcomet? Preferrably also fixing the Listening Port problem I mentioned?

3) How do I manage twice my internet speed after manually rebooting my modem and router?

4) What could cause my NAT settings to change like this, all of a sudden? How can I set it back to Open, if at least for my Xbox 360?

5) Could the cause of this be my router? Is it known to have problems?






Right now, I'm going to upgrade the firmware (if possible) and see if that fixes the issue.

ANY input you guys might have on the matter is much appreciated :)

ZZLEE January 11, 2011 07:22 PM

try a speed test to Mount royal in Montreal

:ph34r: 15 t0 20 Rogers

Mr. Gruntsworthy January 11, 2011 07:29 PM

Quote:

Originally Posted by ZZLEE (Post 473474)
try a speed test to Mount royal in Montreal

:ph34r: 15 t0 20 Rogers

http://www.speedtest.net/result/1107603930.png

0_0

SugarJ January 11, 2011 07:50 PM

Ditch Bitcomet. I used to have similar issues until I moved to uTorrent a couple of years back.

Mr. Gruntsworthy January 11, 2011 08:14 PM

I just fixed the NAT issue, at least. Forced the necessary ports open in my router's Port Range Triggering section.

JMCD January 11, 2011 08:22 PM

The speeds you're getting are speedboost. 10mbit typically sees 18-20mbit for about 10-20 seconds, just long enough to throw a speedtest off, then you'll drop to 10mbit. As for getting throttled that is rogers doing, they throttle torrents. There are some work arounds for this, however I don't use torrents because I find them to be too slow for my liking, usenet all the way. A google search should yield you some things you may try to avoid being throttled. Also check out the dslreports forums under rogers, there's a huge thread about it there and you may find some answers.

LarkStarr January 11, 2011 10:17 PM

quick reply. do NOT use bitcomet. use uTorrent instead.

you also need to limit your upload speed to about 50-75% of your maximum, else your line will become saturated.

ilya January 11, 2011 11:24 PM

I have the exact same package from Rogers as you, I get this speed when I do any kind of internet connection benchmark: http://www.speedtest.net/result/1095931964.png I took that one a week ago I think.

However, any real world d/l gets capped at 8mbit/sec, just under advertised speeds. They never give you your money's worth and make you think you're getting a good deal when you go to check if you are. This is just Rogers being controversial like they always are. Telcom companies all have questionable business practices, especially if they own a sports team or two. If they own the Skydome, (not the Rogers Centre:whistle:) they're typically the worst of them all. Best way to deal with them is to squeeze every penny out of their package deals and bargain like the cheapest <insert racist expletive> you possibly can.

For torrents, uTorrent encryption works fine for me, as long as I don't saturate the upload I can get most of the speed I should be getting on the Express package. Rogers is very serious about torrent throttling, regardless of the legality of their actions or yours.

Don't upgrade the firmware on your modem, the last thing you want is Rogers giving you crap for modifying their modem. (unless you bought it, but still not the best idea) A firmware upgrade on your router probably won't do much either, unless it's an Asus, which it isn't.

JD January 12, 2011 01:32 PM

If TekSavvy cable is in your area, I'd suggest switching. You should be able to get a 15Mbps/1Mbps with 200GB cap for roughly the same price.

No throttling in my area and everything does a solid 1.4MB/s. If I'm luckily I can actually sustain 1.8MB/s as well.

Otherwise, there's nothing noticeably wrong with your service. Once you switch to a better torrent client and cap your upload speed in it to 90% or less (uTorrent has an auto-config which can help) you should be good to go.

Also never trust speed tests on cable. Due to SpeedBoost, you can't get a reliable result. A proper test would be to download a Linux ISO or something of substantial size from a good server.

Mr. Gruntsworthy January 12, 2011 01:38 PM

Hm, I'm going to look into teksavvy. The current internet package, I think, is $50 a month, give or take a few dollars.

How much is the Tekksavy?

If it is the same, it'd be worth it if just for the double upload speed. 512kb/s is kind of sketchy for online gaming, which I do a lot of.

200GB per month is also a nice sexy upgrade from my current 60...


All times are GMT -7. The time now is 03:30 AM.