Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Networking (http://www.hardwarecanucks.com/forum/networking/)
-   -   slow internet speed under windows 7 (http://www.hardwarecanucks.com/forum/networking/25366-slow-internet-speed-under-windows-7-a.html)

Kyure November 10, 2009 02:37 AM

slow internet speed under windows 7
 
hi, for some reason my dasktop which is running windows7 only reach 1~3mpbs
but my macbook pro and xp laptop can reach 11~13mpbs, on the same dask
all running in wireless N

is there any way that I can do to make the internet speed in windows7 better?

Thanks

sswilson November 10, 2009 02:47 AM

How are you connecting? (wireless / direct connection) Are you sure you've got the best drivers? Are you sure all other PCs are disconnected from the network when you're testing the win7 install, and that all bandwidth using programs are turned off?

Kyure November 10, 2009 03:06 AM

connecting through wireless, Im using D-Link DWA-552 and don't think they have new driver for windows7
it doesn't had this problem when Im using vista
and Im not planning to go back to vista

sswilson November 10, 2009 03:08 AM

Try connecting directly to the modem with an ethernet cable for the test. If you get the proper speeds that way then you know that it's something to do with either the wireless card settings or the Win7 drivers.

Cowboy November 10, 2009 07:02 AM

I've got the dwa-542 and I have the EXACT same problem. I can't connect at a decent speed period. I think its the lack of a d-link driver for windows 7. I've been using the vista x64 driver until now.

martin_metal_88 November 10, 2009 12:27 PM

Well customer call us very ofter for this network adapter and trying to find help for speed problem. Most of the time under 7 and XP64. I think it's a lack of god driver for now. D-link is a company I don't really love but one thing is sure they are fast for getting out new and good driver so it wontbe long before the issue get fixed. Ho yeah 800 post:):canadianwave:

Perineum March 17, 2010 02:11 PM

I'm guessing that last post is spam.... ? I don't see the relevance.


All times are GMT -7. The time now is 02:22 AM.