Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Networking (http://www.hardwarecanucks.com/forum/networking/)
-   -   BT Kills Windows Live Messenger (http://www.hardwarecanucks.com/forum/networking/20293-bt-kills-windows-live-messenger.html)

geokilla July 15, 2009 07:03 PM

BT Kills Windows Live Messenger
 
Every time I have BT running on my side computer, I get disconnected from Windows Live Messenger on my own computer. Also even if I don't have BT running, every once in a while I will randomly get kicked out of WLM or not be able to send and receive instant messages, even though my Internet would still be working perfectly fine.

I'm using the latest version of DD-WRT, build 12476M a WRT54GSv7. I have BT running on a side computer with its ports forwarded and UPnP enabled. I also have QoS enabled and have the BT's computer's priority set to bulk in QoS. My own computer has the QoS priority set to Express.

According to the UPNP page, I do not have any WLM ports forwarded. I do have some BT ports forwarded in the UPnP page, despite already having Port Forward setup.

I opened WLM as well and went to the connections tab on the left. It always gives me the following connection status:
Code:

You are directly connected to .NET Messenger service.

You are connected to the Internet through a wired network connection.

You are connected to the Internet through a UPnP port restricted NAT. (Administrator)

It doesn't matter which firmware I use or whether I'm downloading or not. WLM will always say that I have a UPnP port restricted NAT.

When I directly connect my computer to the modem, thus bypassing the router, my ports aren't blocked and everything's fine. WLM says:

Code:

You are directly connected to .NET Messenger service.

You are connected to the Internet through a wired network connection.

You are connected to the Internet using a direct connection. (Administrator)


Silvgearx July 15, 2009 08:04 PM

windows live is a F:angry2:ING piece of shit and it gets worst with every newer version. And whats with the ads, geeezzzzzz :angry2:

use something else like trillian :ph34r:

feel better now :bleh:

Arinoth July 15, 2009 08:10 PM

Yeah, unless i have to use the audio chat or a webcam, i steer completely clear from Windows Live Messenger or any form of msn messenger and keep happy with my more reliable, no adds Trillian Astra

geokilla July 15, 2009 09:53 PM

Well I've been fine with Windows Live Messenger, and it seems that it's not Windows Live Messenger that's giving me this network problem. It's my router that's giving me the problem. Connecting the computer directly to the modem gives me the
Code:

You are connected to the Internet using a direct connection. (Administrator)
which I can't get even if I DMZ or have UPnP enabled when connecting my computer to the router. If it was indeed Windows Live Messenger being stupid, then I would've had problems receiving messages and it wouldn't say that I'm drectly connected to the Internet instead of connecting through a UPnP restricted NAT, whatever that means.

enaberif July 15, 2009 10:01 PM

Why are you even using uPNP? Its garbage.

geokilla July 16, 2009 06:58 AM

Quote:

Originally Posted by enaberif (Post 224248)
Why are you even using uPNP? Its garbage.

UPnP lets the port forward automatically doesn't it? How else can I get a direct connection to the Internet without having my ports blocked by the router...

bojangles July 16, 2009 08:19 AM

uPNP is a huge security hole for one.

Disable uPnP and manually set your ports in the router. I hope you set up a static IP for your computer to use Torrents correctly?

geokilla July 16, 2009 02:04 PM

Quote:

Originally Posted by bojangles (Post 224391)
uPNP is a huge security hole for one.

Disable uPnP and manually set your ports in the router. I hope you set up a static IP for your computer to use Torrents correctly?

Hmm what's wrong with UPnP? I'll disable it and see what happens.

I have static IP setup for all my computers and the correct ports forwarded for BT. As of right now, my Internet usage is very low as I'm just listening to the radio. I've already missed a good chunk of instant messages on WLM with my friends.

Tried connecting my computer directly to the modem this morning for a short while, and I got ALL my instant messages. I'll try again right now.

bojangles July 16, 2009 04:07 PM

Try disabling QoS and set your torrent application to low priority.

Andy July 16, 2009 04:11 PM

For those pissed off with MSN for the ads, take a look into either A-Patch, or the Mess.be patch. You can remove all the ads, and customize tons of other stuff.


All times are GMT -7. The time now is 11:32 AM.