Go Back   Hardware Canucks > SOFTWARE > Networking

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 18, 2009, 12:14 PM
FiXT's Avatar
Hall of Fame
 
Join Date: Apr 2008
Location: GVRD
Posts: 3,343

My System Specs

Default DWL G510 (REV.B&C) Vista 64bit Working Drivers

Hey Folks.
This is more just an informative post for those with the
D-LINK DWL - G510 Xtreme G Wireless Cards for the Rev B (Atheros) and Rev C (Ralink) versions , and for those who may stumble across it in google, and for myself in the future if I ever forget . After hours of searching without luck for the proper drivers I managed to gather enough information to track down the RevB drivers from Atheros and stumbled across a link for the Rev C ones on dlinks website.

Initially with the RevB, Vista64 would install generic Atheros drivers which resulted in very poor and poor signal strength, with the router right next to the card. After the update it jumped to a full 5 bars.

Rev B. Drivers:
vista-7.6.0.126-whql.zip
ATHEROS Wireless LAN 2.4/5GHz - Download Driver AR5002G

The RevC card failed to work right off the bat until these betas were installed.

Rev C. Drivers
DWL-G510 64bitVista Driver 1.0.zip
Download


If these links eventually die, please let me know and I will do my best to update them. I will attempt to host these files sometime soon just in case.
Reply With Quote
  #2 (permalink)  
Old June 18, 2009, 10:10 PM
Rookie
 
Join Date: Feb 2009
Location: Nova Scotia, Canada
Posts: 24

My System Specs

Default

I just installed Windows 7-32bit on one of my old drives. I'm having problems getting windows to detect my Dlink G510 Wireless Pci card. You think these older vista drivers will work?
Reply With Quote
  #3 (permalink)  
Old June 19, 2009, 09:27 AM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,816

My System Specs

Default

That Atheros site has been up for as long as I can remember. Great site for any card that uses Atheros chipsets since apparently manufacturers can't keep things up-to-date.
Reply With Quote
  #4 (permalink)  
Old July 25, 2009, 09:57 AM
Trial Member
 
Join Date: Jul 2009
Posts: 1
Default

Went to the first link in the first thread to download the driver but the only option I see is to download an inf file with a button that says "Download" underneath. When I click that I am brought to a page that doesnt have any download links on it and nothing automatically starts. Would love it if someone had the drivers and could upload them somewhere or something.

Thanx alot.
Reply With Quote
  #5 (permalink)  
Old October 23, 2009, 02:44 AM
Rookie
 
Join Date: Oct 2009
Posts: 3
Default I got mine working

Not sure if it works every time but here is what I did. First, Rev.C has a chipset made by Ralink so I'm surprised to see you looking for Atheros drivers (atheros make their own chipsets no?). Anyway...

I downloaded the Vista x64 drivers from the D-link UK FTP website. I'll give the link in my next post because this is my first post here and the forum won't let me post a link.

Then you start Windows, go to Device Manager and find your adapter. Update drivers to the downloaded ones (works in Windows 7 x64 also).

But that's not it. My experience is that if you try and use your adapter straight away, then your downloads will be throttled to around 1Mbps. The fact is that D-Link recommend that you install drivers BEFORE you install the card. But that's impossible when you only have .inf files and not a full fledged installer. So the solution is to go back to the device manage, find the adapter.
1. Right click and choose Uninstall. Then you get a message to confirm and then in the bottom there is a tick box saying something like: do you want to remove the drivers. DO NOT TICK THE BOX. Proceed.

2. Shut down the computer. Remove the card. Reboot. Shut Down. Install the card. Reboot. Voila!!!
(to be honest it might be ok, instead of 2., to just scan for hardware. But I'm to afraid to mess it up so I don't want to try)

I finally got full download speed on Windows 7 RC x64.

Any questions, let me know.
Reply With Quote
  #6 (permalink)  
Old October 23, 2009, 02:44 AM
Rookie
 
Join Date: Oct 2009
Posts: 3
Default I got mine working (2)

Here is the link mentioned above:

ftp://ftp.dlink.co.uk/wireless/dwl-g...a64_rev_Cx.zip

Hope that helps.
Reply With Quote
  #7 (permalink)  
Old October 23, 2009, 04:00 AM
Rookie
 
Join Date: Oct 2009
Posts: 3
Default

I finally got the guts to give it a go: if you refer to my first post, it would appear that just rescanning for hardware in the device manager is enough. Worked for me (maybe it was that it wasn't on a clean install and I had already successfully installed the drivers through the slightly longer shutdown route. I did uninstall everything, drivers included, after that though). Will try it on a clean install of Win7 x64 (it's on a test box so I don't really care).
Reply With Quote
  #8 (permalink)  
Old October 28, 2009, 02:21 PM
Rookie
 
Join Date: Oct 2009
Posts: 2
Default

I'm afraid I have this throttling problem. Not as bad as described as I get 3Mb/s instead of 8Mb/s with my laptop, but still it's really annoying. I've tried the trick to deinstall the driver, remove card, reboot, shut down, install card and reboot but I'mm still stuck at 3Mb/s...
I do have the official Win 7 version build 7600 and I'm getting out of ideas on how to fix this issue...
Reply With Quote
  #9 (permalink)  
Old October 28, 2009, 03:20 PM
Rookie
 
Join Date: Oct 2009
Posts: 2
Default

Additionnal question though, I notice that the driver I have installed is a 2007 version from Ralink which I guess was designed for Vista. It seems that Ralink has issued some windows 7 RT61, so I was wondering if they would work better. Unfortunately I have no clue which to use (there is a regular WLAN card, a turbo card, a mimo version...) and Win7 failed to recognized the files when I tried to use them manually... Anyone tried those?
Reply With Quote
  #10 (permalink)  
Old March 30, 2010, 11:14 AM
Gew's Avatar
Gew Gew is offline
Rookie
 
Join Date: Mar 2010
Location: Kingston, Jamaica.
Posts: 2
Exclamation

Unsure if this is still a topic of issue, but I find it safe to say that D-Link seems to have done their homework. Specific W7 drivers (x86 aswell as x64) are now available, at least for Rev. C.

DWL-G510_drv_RevC_v5.20-s0038-20090909.zip

Quote:
File name Size
----------------------- ---------------
Drivers\
Drivers\Win2K_XP\
NetRt61G.INF 28,984
NetRT61G.CAT 8,481
rt61.sys 500,096
Drivers\Win7x64\
NetRT61G.CAT 8,871
NetRt61G.INF 15,516
rt61.sys 438,784
Drivers\Win7x86\
NetRt61G.INF 15,519
NetRT61G.CAT 8,856
rt61.sys 368,128
Drivers\WinVistax64\
NetRT61G.INF 22,809
NetRT61G.cat 8,866
RT61.sys 393,216
Drivers\WinVistax86\
NetRT61G.cat 8,864
NetRt61G.INF 22,789
RT61.sys 335,872
Drivers\WinXPx64\
NetRt61G.INF 29,001
NetRT61G.CAT 8,505
rt61.sys 460,288

total files 18 total size 2,683,445
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
64bit OEM Vista on multiple computers? Evylldemon O/S's, Drivers & General Software 17 October 3, 2009 11:52 AM
XP? Vista? 32bit? 64bit? 7? RainMaker O/S's, Drivers & General Software 30 January 13, 2009 06:08 PM
Vista 32bit or 64bit for gaming cndian O/S's, Drivers & General Software 54 December 10, 2008 05:47 PM
viewsonic drivers + vista 64= not working CTA Troubleshooting 6 October 24, 2008 08:16 AM
Is it time for Vista 64bit? magictorch O/S's, Drivers & General Software 41 July 19, 2008 12:50 PM