Go Back   Hardware Canucks > Mac, iPhone & iPod > Mac

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 16, 2013, 12:48 PM
Kommie986's Avatar
Allstar
 
Join Date: May 2010
Location: Waterloo, Ontario
Posts: 601

My System Specs

Default MacBook Pro Audio Jack Static

I got a MacBook Pro for Christmas, which I am using for school ATM and I've noticed a pretty annoying issue. About 1/3 of the time when I have my earphones (Apple EarPods) plugged in, I hear static feedback. IDK how to fix it. I've tried turning the plug and unplugging then plugging it back in. The static is still there and just disappears after a while on its own. Anyone else have this kind of problem? Also, what should I do?
Reply With Quote
  #2 (permalink)  
Old January 16, 2013, 01:05 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,580

My System Specs

Default

Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion
Reply With Quote
  #3 (permalink)  
Old January 16, 2013, 01:13 PM
Kommie986's Avatar
Allstar
 
Join Date: May 2010
Location: Waterloo, Ontario
Posts: 601

My System Specs

Default

Quote:
Originally Posted by Arinoth View Post
Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion
The MacBook audio port is in and out (like phone). I will use the earphones that were included with my Galaxy Nexus to test whether it's just an issue with my earphones.
Also, I called Apple Support and they instructed me to so some resets. Hopefully those work.
Reply With Quote
  #4 (permalink)  
Old January 17, 2013, 01:20 PM
ultraman7k's Avatar
Allstar
 
Join Date: Oct 2009
Location: Surrey, B.C.
Posts: 527

My System Specs

Default

I'll test mine out when I get home and see if I have the same issue.
Reply With Quote
  #5 (permalink)  
Old January 17, 2013, 06:28 PM
Kommie986's Avatar
Allstar
 
Join Date: May 2010
Location: Waterloo, Ontario
Posts: 601

My System Specs

Default

I think the problem may be with the earphones. I don't get the issue with the ones that came with my Galaxy Nexus. Looks like I gotta RMA some earphones 0_o
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need static IP options chrisk Networking 11 September 6, 2011 11:29 AM
Static Control Reyzac New Builds 15 June 5, 2011 03:13 PM
did i just my 8800gt with static? kuziwk Video Cards 10 February 3, 2010 11:50 AM
S/PDIF jack? biff HTPC Systems & Software 10 March 18, 2009 09:34 PM
Static In My Sound? kcksteve Audio 7 August 31, 2007 10:49 AM