Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Mac (http://www.hardwarecanucks.com/forum/mac/)
-   -   MacBook Pro Audio Jack Static (http://www.hardwarecanucks.com/forum/mac/59177-macbook-pro-audio-jack-static.html)

Kommie986 January 16, 2013 12:48 PM

MacBook Pro Audio Jack Static
 
I got a MacBook Pro for Christmas, which I am using for school ATM and I've noticed a pretty annoying issue. About 1/3 of the time when I have my earphones (Apple EarPods) plugged in, I hear static feedback. IDK how to fix it. I've tried turning the plug and unplugging then plugging it back in. The static is still there and just disappears after a while on its own. Anyone else have this kind of problem? Also, what should I do?

Arinoth January 16, 2013 01:05 PM

Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion

Kommie986 January 16, 2013 01:13 PM

Quote:

Originally Posted by Arinoth (Post 684730)
Does it happen to any ear phones or speakers plugged into it or just the ones you are using (Apple EarPods)

I had an issue using my phone head phones in computer speaker jacks since it has an extra connector for the mic which was causing the static feedback. Unless the device, such as a phone or tablet has the 3 connectors which include the microphone any headphones that have a mic in them will cause static feedback or some kind of distortion

The MacBook audio port is in and out (like phone). I will use the earphones that were included with my Galaxy Nexus to test whether it's just an issue with my earphones.
Also, I called Apple Support and they instructed me to so some resets. Hopefully those work.

ultraman7k January 17, 2013 01:20 PM

I'll test mine out when I get home and see if I have the same issue.

Kommie986 January 17, 2013 06:28 PM

I think the problem may be with the earphones. I don't get the issue with the ones that came with my Galaxy Nexus. Looks like I gotta RMA some earphones 0_o


All times are GMT -7. The time now is 11:27 AM.