Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Mac (http://www.hardwarecanucks.com/forum/mac/)
-   -   Connecting to OSX share from Windows 7 (http://www.hardwarecanucks.com/forum/mac/45498-connecting-osx-share-windows-7-a.html)

lowfat August 8, 2011 12:38 PM

Connecting to OSX share from Windows 7
 
Trying to have one of my Windows 7 machines mount an shared folder from my iMac. It always refuses the password though. The only way I can seem to get it to work is if I setup a guest account and use that, however then it has no password, which I don't want.

http://hostthenpost.org/uploads/c6ff...a931918c20.png

Anyone successfully able to access an OSX share from Windows w/o using a guest account?

I am using Home Premium and have added LmCompatibilityLevel in the registry. Doesn't seem to help though.

futures August 26, 2011 09:47 AM

If you haven't already got the sharing working... make sure SMB protocol is enabled on both ends ?? Does it work the other way around Mac to NTFS.. with NTFS-3G or similar program ?? Have you tried creating other accounts on the MAC side.. matching account names and pass?

lowfat August 26, 2011 04:52 PM

I've already come to the conclusion that Lion just plain ol' sucks. SMB is hooped with it. I was wrong in thinking that a guest account works. There is zero ways to get any of my computers able to connect to an OSX share.

I have no problems seeing any of my Windows machines and have no problems reading and writing to their shared drives. Seems to be broken for almost everyone on the internet too. If it isn't resolved by the next update I'll just go back to Snow Leopard.

Mistertuxedopants September 23, 2011 07:01 AM

I had the same problem to access a shared drive from your mac on your windows PC you have to make a few changes in Local Security Policy
Go to control panel -> Administrative Tools -> Local Security Policy

Once there go to Local Polices -> Security Options
  • Network Security: Lan Manager authentication level -> set this to
    "Send LM & NTLM - use NTLMv2 Session if negotiated"
  • Network Security: Minimum session security for NTLM SSP Based (there are 2 of these)
    Make sure both boxes are unchecked in each one
This worked for me
Cheers!

lowfat September 23, 2011 08:54 PM

Quote:

Originally Posted by Mistertuxedopants (Post 551398)
I had the same problem to access a shared drive from your mac on your windows PC you have to make a few changes in Local Security Policy
Go to control panel -> Administrative Tools -> Local Security Policy

Once there go to Local Polices -> Security Options
  • Network Security: Lan Manager authentication level -> set this to
    "Send LM & NTLM - use NTLMv2 Session if negotiated"
  • Network Security: Minimum session security for NTLM SSP Based (there are 2 of these)
    Make sure both boxes are unchecked in each one
This worked for me
Cheers!

Had this already done since every time I rebooted my PC's I needed to login to access the share. However this was w/ Snow Leopard. Even with these changes it refuses to accept the password w/ Lion.

I'll also add this is only possible w/ Professional copies of Windows. Local Policy Editor isn't included w/ Home Premium.

Mistertuxedopants September 24, 2011 10:03 AM

That sucks, sharing drives from Lion to my windows and unix boxes works great for me... maybe its because I am using Windows 7 Professional

lowfat September 24, 2011 12:33 PM

I use Professional on one of my computers too. Makes no difference. Everytime you try to access the share it won't accept the password. Seems to be a huge issue w/ Lion. Google search brings up a whole lot of results. You are honestly the first person I've seen that got it to work.

LarkStarr September 24, 2011 10:24 PM

probably isn't using a password

lowfat September 26, 2011 02:47 PM

Quote:

Originally Posted by LarkStarr (Post 551907)
probably isn't using a password

I'm definitely using a password. SMB is just broken.

LarkStarr September 26, 2011 06:43 PM

Nooo, the dude above you. That got it to work.


All times are GMT -7. The time now is 10:36 AM.