Go Back   Hardware Canucks > Mac, iPhone & iPod > iPhone & iPods

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old November 26, 2011, 03:47 PM
KRAFTIG's Avatar
Top Prospect
 
Join Date: Sep 2010
Posts: 60
Exclamation Installing iTunes 10.5.1 on Win 7 64 Bit no go!?!

Anyone else have this problem? Is there a solution? TIA!
Reply With Quote
  #2 (permalink)  
Old November 26, 2011, 03:52 PM
Top Prospect
 
Join Date: Nov 2011
Posts: 159

My System Specs

Default

im using it and have no problems, you should try deleting all the apple stuff in registry editor and reinstall itunes
Reply With Quote
  #3 (permalink)  
Old November 26, 2011, 03:57 PM
KRAFTIG's Avatar
Top Prospect
 
Join Date: Sep 2010
Posts: 60
Default

Quote:
Originally Posted by Ed103194 View Post
im using it and have no problems, you should try deleting all the apple stuff in registry editor and reinstall itunes

How do I do that? TIA!
Reply With Quote
  #4 (permalink)  
Old November 26, 2011, 04:14 PM
Top Prospect
 
Join Date: Nov 2011
Posts: 159

My System Specs

Default

you are using 64bit windows right? did you try reinstalling it?

if you tried reinstalling and it didnt work, then uninstall first

then press windows key+r

type regedit

go to local machines/software, right click apple inc and click delete, then install again

you can always install 32bit if it still doesnt work
Reply With Quote
  #5 (permalink)  
Old November 26, 2011, 04:47 PM
KRAFTIG's Avatar
Top Prospect
 
Join Date: Sep 2010
Posts: 60
Default

It didn't work. I was also on the phone with an Apple tech eariler, he wasn't much help and blamed MS for the issue, lol.

Also it won't allow me to install 32-bit, the installer tells me to install 64 bit when I try. Here's the errors during install:







Last edited by KRAFTIG; November 26, 2011 at 07:01 PM.
Reply With Quote
  #6 (permalink)  
Old November 27, 2011, 12:41 PM
but2002's Avatar
Rookie
 
Join Date: Nov 2011
Posts: 18

My System Specs

Default

Did you try running the installer as Administrator?
Reply With Quote
  #7 (permalink)  
Old November 27, 2011, 02:03 PM
KRAFTIG's Avatar
Top Prospect
 
Join Date: Sep 2010
Posts: 60
Default

Quote:
Originally Posted by but2002 View Post
Did you try running the installer as Administrator?

If that entails right clicking on the .exe file and selecting admin, yes.
Reply With Quote
  #8 (permalink)  
Old November 29, 2011, 04:43 PM
ultraman7k's Avatar
Allstar
 
Join Date: Oct 2009
Location: Surrey, B.C.
Posts: 527

My System Specs

Default

I had this problem when I didn't do a fresh install of win7 over vista a couple years ago.

Ended up having to format and do a clean install. Problem solved.
Reply With Quote
  #9 (permalink)  
Old November 29, 2011, 05:00 PM
KRAFTIG's Avatar
Top Prospect
 
Join Date: Sep 2010
Posts: 60
Default

Quote:
Originally Posted by ultraman7k View Post
I had this problem when I didn't do a fresh install of win7 over vista a couple years ago.

Ended up having to format and do a clean install. Problem solved.
This is a new install no upgrade, been running fine for 6-8 months... Thanks.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
iTunes Question PH93 iPhone & iPods 7 September 2, 2011 09:45 AM
iTunes 9 Trackinfo LC0g O/S's, Drivers & General Software 4 February 17, 2010 06:56 PM
Itunes pops up randomly Cadence O/S's, Drivers & General Software 6 August 28, 2009 07:27 PM
iTunes Transfer darkorb Networking 3 September 10, 2008 06:55 PM
BSOD from iTunes? :| curtispan Troubleshooting 3 January 5, 2008 03:23 AM