Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   HardwareCanucks F@H Team (http://www.hardwarecanucks.com/forum/hardwarecanucks-f-h-team/)
-   -   GPU3 goes to sleep after a WU is completed (http://www.hardwarecanucks.com/forum/hardwarecanucks-f-h-team/53021-gpu3-goes-sleep-after-wu-completed.html)

Sk00maKing April 4, 2012 06:52 AM

GPU3 goes to sleep after a WU is completed
 
Hi,

I am pretty new to folding, but i have one single annoying problem that i can't seem to resolved by myself.

On one of my folding rig, i fold on a GTX460 under windows with GPU3, it is able to complete a full WU without problem, BUT, when i tries to start another wu, i receive the following message:

Quote:

[19:58:06]Folding@Home will go to sleep for 1 day as there have been 5 consecutive Cores executed which failed to complete a work unit.
[19:58:06] (To wake it up early, quit the application and restart it.)
[19:58:06] If problems persist, please visit our website at http://folding.stanford.edu for help.
[19:58:06] + Sleeping...
I have to kill and restart the client and everything goes alright for a full wu...

Here is what i tried:

- Go from systray client to command line one.
- Moved the source folder from my user folder tree to the root of another partition.
- Force the exe to run as administrator.
- Run the exe in a console that is started as administrator.

All of this changed nothing, client always finish its job and go to sleep until i restart it manually.

That machine also folds on 7/8 of the cpu threads available.

Anyone has an idea on how to resolve this problem?

Thanks!
Sk00.

lowfat April 4, 2012 07:20 AM

This is what I've been dealing w/ for a week on my GTX460. Look in your log to see if what you are getting for the error. Mine Core status = 63.

sswilson April 4, 2012 07:45 AM

Are you running the latest drivers? If so, the power saving features don't play nice with FAH. You need to either drop back to older drivers, or disable the "turn off monitor" power saving feature(s).

lowfat April 4, 2012 08:15 AM

Quote:

Originally Posted by sswilson (Post 617722)
Are you running the latest drivers? If so, the power saving features don't play nice with FAH. You need to either drop back to older drivers, or disable the "turn off monitor" power saving feature(s).

Trying this. Will attempt back after a WU or two to see if it resolves issue.

MARSTG April 4, 2012 08:26 AM

or just go in driver settings and specify to use max performance instead of adaptive settings. My card is a GT430. I had very good experience with driver 260.99 in the past, which allows for smooth operation on the desktop while GPU folding, but now I am using latest WHQL driver from nvidia for the 400 Series, 295 something. It is a bit choppy so I don't GPU fold while I am doing stuff on my PC, onlyduring the nights and when I am not home.

lowfat April 4, 2012 08:46 AM

Sk00maKing, I don't suppose you have problems w/ pausing the client as well? When I pause the client, the GPU keeps on getting used by the client, but no work is being processed until I unpause it. Using the 6.41 system tray client.

geokilla April 4, 2012 09:05 AM

Try installing the V7 beta client. I haven't gotten any problems with V7 beta.

You must disable the "Turn Monitor Off" function, otherwise it will screw up your folding.

frontier204 April 4, 2012 08:17 PM

Thanks for confirming what I'm seeing too on a GTX 550 Ti. I've been folding without any problems when I stopped Windows from turning off the monitor (which I do myself anyway).
EDIT: Note I also disabled PCIE Link State Power Management just as a precaution. I wonder if AMD's Zero Core power will start blowing up as well?

...looks like F@H is going back to being high maintenance... This bug cost me a pile of debugging time moving my GPU between computers, and had me get another PSU when I didn't need it :blarg:

sswilson April 4, 2012 08:22 PM

Apparently this is just related to the newest WHQL nvidia drivers. It's a tradeoff between latest drivers for gaming performance but disabling monitor power saving shutoff feature(s), or using older drivers for convenience.

I stayed with the latest drivers on my main rig for the improvements to Skyrim, but left the older drivers on my folding / network storage PC.

Sk00maKing April 5, 2012 07:25 AM

Quote:

Originally Posted by lowfat (Post 617753)
Sk00maKing, I don't suppose you have problems w/ pausing the client as well? When I pause the client, the GPU keeps on getting used by the client, but no work is being processed until I unpause it. Using the 6.41 system tray client.

I did not had any problem w/pausing while i was using the systray version but still, the client could not start a second wu...

My current drivers are 295.73.

About the monitor turn off function, it would prevent from starting a NEW wu, but it's no problem for the current one to finish?

I will try that and let you guys know if it fixed the problem.

Thanks


All times are GMT -7. The time now is 11:35 PM.