Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   HardwareCanucks F@H Team (http://www.hardwarecanucks.com/forum/hardwarecanucks-f-h-team/)
-   -   SMP Folding @ 50% to 75% = 0 Progress?! (http://www.hardwarecanucks.com/forum/hardwarecanucks-f-h-team/47288-smp-folding-50-75-0-progress.html)

geokilla October 13, 2011 03:05 PM

SMP Folding @ 50% to 75% = 0 Progress?!
 
I have my SMP client folding at 50% to 75% because lately, me botting in RuneScape requires 25% to 50% CPU overhead. However with the A3 core chugging along at 50% to 75% CPU usage, my TPF is over 2 hours. What the hell?! Is there a way to fix this? How can a 25% to 50% drop in CPU resources result in such a huge drop in TPF? Even my old Athlon X2 can fold better than this.

Dead Things October 13, 2011 03:38 PM

Sounds like an affinity problem. That is, thread imbalance such that the core is spending a big chunk of its CPU cycles waiting.

Think of it like this:

00:00 Thread 1 starts job 1a
00:00 Thread 2 starts job 2a
00:30 Thread 1 finishes job 1a
00:45 Thread 2 finishes job 2a
00:45 Thread 1 starts job 1b
00:45 Thread 2 starts job 2b

Since thread 1 can't start job 1b until it gets the job 2a information from thread 2, then its CPU time between 00:30 and 00:45 is just cycling in wait, not really doing anything. The more threads you have, the more they will have to wait if their cycles fall out of symmetry, and when this happens to a symmetrical task with linear progression such as fah, it could cause all kinds of problems.

So to reduce CPU usage, you would probably be better served by doing all of the following:

a) Leaving usage at 100% in the client config
b) Using the smp flag to reduce the number of processing threads available to fahcore
c) Using a program like WinAFC to assign and limit the fahcore to specific threads

That way, the process will maintain better symmetry and waste fewer CPU cycles waiting.

geokilla October 13, 2011 05:14 PM

Reducing the number of cores by using -smp 3 flag doesn't help. Been one hour now and still 0 progress. Also doesn't explain why my sister's Phenom II can manage to have a TPF of around 15 minutes while she plays her Facebook games or MapleStory. Those games use at the very least 25% of CPU overhead, just like my bots in RuneScape.

chrisk October 13, 2011 05:44 PM

Try deleting the WU and queue files.

geokilla October 13, 2011 07:56 PM

Quote:

Originally Posted by chrisk (Post 557430)
Try deleting the WU and queue files.

I think it might've been because I had -smp 2 and -smp flags, which meant the -smp flag had more priority to use as many cores as possible. Going to give it another try.

Still doesn't explain why I can still fold normally with a linear drop in PPD when I run flash in 720P or why my sister can still put out TPF of about 15 minutes when she plays her games....

Dead Things October 13, 2011 08:20 PM

Quote:

Originally Posted by geokilla (Post 557484)
Still doesn't explain why I can still fold normally with a linear drop in PPD when I run flash in 720P or why my sister can still put out TPF of about 15 minutes when she plays her games....

No it doesn't. Which is why Chris might be right about the WU being borked. Do you see any mention of the WU you're working on in here?


All times are GMT -7. The time now is 04:13 PM.