Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Gaming (http://www.hardwarecanucks.com/forum/gaming/)
-   -   Need a software sale rep (http://www.hardwarecanucks.com/forum/gaming/58574-need-software-sale-rep.html)

LoTech December 16, 2012 08:04 AM

Need a software sale rep
 
Not sure if this is the place to post this. I have a UBISOFT promo code for Assasins Creed III. I go to redeem the code and site says code invalid. I received the code for a purchase I made on Amazon on black friday. I bought a Samsung SSD. I was wondering if there is anyone that works in the electronic retail business that may have contact with a Ubisoft rep. etc. I need a lead to pursue as the forums and Amazon have been silent to my emails since the purchase. To be honest, ubisoft is a hard nut to crack to get an email address for their PR people. They want you to join a forum and post a question.....geez just give me the address, I have a complaint.
It shouldn't be this hard.

sswilson December 16, 2012 09:29 AM

There was a post about this somewhere, apparently you have to put the game in your cart and even go so far as to enter your CC information but once that's done the code apparently works.

IIRC Skymtl was talking about it so if you do a search through his posts you'll probably find the appropriate thread (it was within the last week or so).

LoTech December 16, 2012 11:07 AM

Thanks will do the search. I have tried this from a proxy server as well since I live in Canada, but I bought it from USA. The proxy never worked either. The reason I went proxy was because, everytime I tried to redeem the promo Ubi redirects me to Canadian UBi site. I figured you could not use the code in Canada and from a CDN IP address. I then had my buddy in California try with my info, he failed as well. I get to the site etc and do all that my email asks of me and in the order they say, but when the code goes into it it says invalid.
I will search it, and thx for the lead sswilson.

sswilson December 16, 2012 11:09 AM

Yeah, that sounds exactly like the situation they were describing in the other thread.


All times are GMT -7. The time now is 07:02 AM.